summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74a981126b29..e91140b9a94a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=spacefm-git
pkgver=1.0.6.r80.ge257d15
-pkgrel=2
+pkgrel=3
pkgdesc="Multi-panel tabbed file manager"
arch=(i686 x86_64)
url="https://ignorantguru.github.io/spacefm"
license=(GPL3)
conflicts=(spacefm)
provides=(spacefm)
-makedepends=(intltool git gcc8)
+makedepends=(intltool git)
depends=(gtk3 startup-notification ffmpegthumbnailer)
optdepends=('dbus: dbus integration'
'util-linux: disk eject support'
@@ -27,12 +27,12 @@ optdepends=('dbus: dbus integration'
'ifuse: mount your iPhone/iPod Touch'
'fuseiso: mount ISO files')
source=("git+https://github.com/IgnorantGuru/spacefm.git#branch=alpha"
+ "https://github.com/FabioLolix/AUR-artifacts/raw/master/spacefm-Fix-GCC-10-build.patch"
"https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/spacefm-glibc-2.28-compatibility.patch")
sha256sums=('SKIP'
+ '16622d0d56c40e87e846a81709d9c2c8303f189e53a783bf20ccdb57b8f9465f'
'12411055df994211d2968cb52746b6caefce6926aed1ed33b542bd70b571ce7e')
-export CC=/usr/bin/gcc-8 CXX=/usr/bin/g++-8
-
pkgver() {
cd "spacefm"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -41,6 +41,7 @@ pkgver() {
prepare() {
cd "spacefm"
patch -Np1 -i ../spacefm-glibc-2.28-compatibility.patch
+ patch -Np1 -i ../spacefm-Fix-GCC-10-build.patch
NOCONFIGURE=1 ./autogen.sh
}