summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf6c03b65f7e..cbeb63c083fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wsjtx-superbuild-git
pkgver=r35.491536f
-pkgrel=4
+pkgrel=5
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) - Superbuild/git version, hamlib not required'
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
@@ -12,13 +12,11 @@ makedepends=('cmake' 'git' 'asciidoc' 'asciidoctor' 'qt5-tools' 'gcc-fortran')
provides=('wsjtx')
conflicts=('wsjtx')
source=('git+https://git.code.sf.net/p/wsjt/wsjtx-superbuild/'
- 'wsjtx.patch'
'repo.patch')
md5sums=('SKIP'
- 'f50bfe0cb3d7bf91ee9b6b6302b78d65'
'd7446a4c8d44880b1c772493a7f170c6')
#set branch to build with WSJTX_TAG variable, or a specific version eg. wsjtx-1.9.0
-_wsjtx_tag=wsjtx-2.1.2
+_wsjtx_tag=master
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -27,7 +25,6 @@ pkgver() {
build() {
patch -p1 -i repo.patch
- cp wsjtx.patch "$srcdir/${pkgname%-git}"
mkdir -p "$srcdir/${pkgname%-git}/build"
cd "$srcdir/${pkgname%-git}/build"
cmake -DWSJTX_TAG=$_wsjtx_tag -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..