summarylogtreecommitdiffstats
path: root/fcommon.patch
diff options
context:
space:
mode:
Diffstat (limited to 'fcommon.patch')
-rw-r--r--fcommon.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/fcommon.patch b/fcommon.patch
new file mode 100644
index 000000000000..d78ae6c83bbc
--- /dev/null
+++ b/fcommon.patch
@@ -0,0 +1,13 @@
+--- a/Makefile 2020-07-08 12:01:24.594082043 +0100
++++ b/Makefile 2020-07-08 12:01:42.124395380 +0100
+@@ -12,8 +12,8 @@
+ ARCH = -m64
+ endif
+
+-CFLAGS = $(ARCH) -O3 -std=gnu11 -Wall -mpclmul -march=core2 -mfpmath=sse -mssse3 -fno-strict-aliasing -fno-strict-overflow -fwrapv -DAES=1 -DCOMMIT=\"${COMMIT}\" -D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64
+-LDFLAGS = $(ARCH) -ggdb -rdynamic -lm -lrt -lcrypto -lz -lpthread -lcrypto
++CFLAGS = $(ARCH) -fcommon -O3 -std=gnu11 -Wall -mpclmul -march=core2 -mfpmath=sse -mssse3 -fno-strict-aliasing -fno-strict-overflow -fwrapv -DAES=1 -DCOMMIT=\"${COMMIT}\" -D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64
++LDFLAGS = $(ARCH) -fcommon -ggdb -rdynamic -lm -lrt -lcrypto -lz -lpthread -lcrypto
+
+ LIB = ${OBJ}/lib
+ CINCLUDE = -iquote common -iquote .