Package Details: appflowy-git latest-18

Git Clone URL: (read-only, click to copy)
Package Base: appflowy-git
Description: An open-source alternative to Notion.
Upstream URL:
Licenses: AGPL3
Conflicts: appflowy, appflowy-bin
Provides: appflowy
Submitter: MithicSpirit
Maintainer: MithicSpirit
Last Packager: MithicSpirit
Votes: 2
Popularity: 0.000002
First Submitted: 2022-05-21 01:21 (UTC)
Last Updated: 2024-03-10 04:54 (UTC)

Latest Comments

1 2 Next › Last »

vschwaberow commented on 2023-09-05 15:35 (UTC)

Works perfect! Many thanks!

MithicSpirit commented on 2023-09-04 22:54 (UTC)

@vschwaberow I've updated the PKGBUILD, can you check whether it is working now?

MithicSpirit commented on 2023-09-04 20:42 (UTC)

Thanks for reminding me to work on this. I was a bit busy so I couldn't do it when I first noticed the issue (ngl I was hoping that it was just a problem upstream that would be addressed by them) but I'll try to see what I can do now.

vschwaberow commented on 2023-09-04 05:34 (UTC) (edited on 2023-09-04 05:34 (UTC) by vschwaberow)

I can't build the package. Do you have any suggestions, what is going wrong here?

[   +5 ms] Building Linux application... (completed in 99,8s)
[        ] "flutter linux" took 108.900ms.
[  +10 ms] ensureAnalyticsSent: 0ms
[        ] Running 0 shutdown hooks
[        ] Shutdown hooks complete
[        ] exiting with code 0
[cargo-make][1] INFO - Running Task: copy-to-product
[cargo-make][1] INFO - Running Task: create-release-archive
[cargo-make][1] INFO - Build Done in 775.60 seconds.
[cargo-make] INFO - Build Done in 775.99 seconds.
==> Betrete fakeroot Umgebung...
==> Beginne package()...
rm: das Entfernen von '/home/volker/.cache/yay/appflowy-git/pkg/appflowy-git/opt/appflowy-git/appflowy.desktop.temp' ist nicht möglich: Datei oder Verzeichnis nicht gefunden
==> FEHLER: Ein Fehler geschah in package().
    Breche ab...
 -> Fehler beim Erstellen: appflowy-git-exit status 4
 -> Die folgenden Pakete konnten nicht installiert werden. Ein manueller Eingriff ist erforderlich:
appflowy-git - exit status 4

MithicSpirit commented on 2023-04-29 17:53 (UTC) (edited on 2023-04-29 17:57 (UTC) by MithicSpirit)

@Moilleadoir I always build every package in a clean chroot, so I don't have them installed already. You do seem to have a very old version of cargo installed, so that might be the issue; try updating it through rustup or switching to using the regular rust package.

EDIT: it seems like your issue might be that the cargo registry is not up to date. If updating cargo doesn't work you can try forcing it to resync the registry by deleting the current one in ~/.cargo/registry (if it's not there then it should be in $CARGO_HOME/registry), which will force it to regenerate it. There's also the option of building in a clean chroot, which is explained in the Wiki (some AUR helpers like paru also have support for doing so)

Moilleadoir commented on 2023-04-29 06:03 (UTC) (edited on 2023-04-29 06:03 (UTC) by Moilleadoir)

Same error. I’m guessing you wouldn’t see this if you already have the tools installed. Crates & cargo-make are something to do with Rust, right? The temp file mentioned points me to

~/.rustup/toolchains/stable-x86_64-unknown-linux-gnu/bin$ ./cargo -V
cargo 1.51.0 (43b129a20 2021-03-16)

Not sure what added this or when, but is the version significant?

MithicSpirit commented on 2023-04-29 01:03 (UTC)

@Moilleadoir I couldn't reproduce that issue, but in attempting to do so found (and fixed) some other problems that cropped up recently. Could you try to rebuild and see if it works now?

Moilleadoir commented on 2023-04-27 06:13 (UTC)

Build is failing for me:

==> Making package: appflowy-git 0.0.9.r312.c8f740147-1 (Déar 27 Aib 2023 15:46:20)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
    Updating index
  Installing cargo-make v0.36.7
error: failed to compile `cargo-make v0.36.7`, intermediate artifacts can be found at `/tmp/cargo-installoqP53a`

Caused by:
  failed to select a version for the requirement `toml = "^0.7"`
  candidate versions found which didn't match: 0.5.11, 0.5.10, 0.5.9, ...
  location searched: index
  required by package `cargo-make v0.36.7`

MithicSpirit commented on 2023-03-02 15:15 (UTC)

@Dieter_be References to $srcdir are not optimal but usually do not matter (very common in rust projects). The issue is usually when there is a reference to $pkgdir.

Dieter_be commented on 2023-03-02 12:44 (UTC) (edited on 2023-03-02 12:44 (UTC) by Dieter_be)

@MithicSpirit, perhaps this is causing the problem:

==> WARNING: Package contains reference to $srcdir