Package Details: aria2-fast 1.36.0-3

Git Clone URL: https://aur.archlinux.org/aria2-fast.git (read-only, click to copy)
Package Base: aria2-fast
Description: Aria2 Download utility with little patch to maximize aria2 download speed
Upstream URL: http://aria2.sourceforge.net/
Licenses: GPL
Conflicts: aria2
Provides: aria2
Submitter: agus.winger
Maintainer: pandada8
Last Packager: pandada8
Votes: 20
Popularity: 0.150596
First Submitted: 2012-05-31 12:24 (UTC)
Last Updated: 2022-01-08 12:38 (UTC)

Required by (70)

Sources (2)

Latest Comments

1 2 Next › Last »

AvianaCruz commented on 2022-05-02 09:12 (UTC) (edited on 2022-05-02 09:16 (UTC) by AvianaCruz)

Please remove the same lines:

-        PREF_PIECE_LENGTH, TEXT_PIECE_LENGTH, "1M", 1_m, 1_g));
+        PREF_PIECE_LENGTH, TEXT_PIECE_LENGTH, "1M", 1_m, 1_g));

pandada8 commented on 2022-03-21 13:10 (UTC)

@mizzunet According to https://wiki.archlinux.org/title/Arch_User_Repository#Prerequisites

Note: Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as build dependencies explicitly.

you should consider install base-devel, which should contain the tools you needed

mizzunet commented on 2022-03-21 13:07 (UTC)

checking for cl.exe... no
configure: error: in `/home/missu/.cache/yay/aria2-fast/src/aria2-1.36.0':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details
==> ERROR: A failure occurred in build().
    Aborting...
checking dependencies...

Add gcc make as make dependencies

kenzanin commented on 2021-04-09 11:41 (UTC)

@redfanglicker check .patch file

normalname012 commented on 2020-02-21 08:46 (UTC)

hows this different from the normal version?

Kr1ss commented on 2019-07-07 13:06 (UTC) (edited on 2019-07-07 13:08 (UTC) by Kr1ss)

Hi, thx a lot for maintaining this package !

I stumbled over the recent update of core/nettle, since this has bumped a shared object library (libnettle.so.{6.5,7.0}), causing aria2c to fail at runtime. However, rebuilding aria2-fast against nettle 3.5.1 solves the issue.

Maybe you could increase the pkgrel to indicate that a rebuild is necessary when a user updates their system ?

Cheers !

pandada8 commented on 2018-10-07 04:50 (UTC)

@DDoSolitary, sorry, should be fixed

DDoSolitary commented on 2018-10-07 00:43 (UTC)

Build failing, please update md5sums for aria2-fast.patch

lifehome commented on 2016-09-09 10:23 (UTC)

aria2 1.26.1 is out, plus the git source link is not updated to aria2/aria2. Please fix this <3

ryansito commented on 2016-01-11 22:00 (UTC) (edited on 2016-01-11 22:15 (UTC) by ryansito)

@pandada8 I've fixed it, I was blocking the multicast port so I've opened it in the firewall. Thanks!!