Package Details: astc-encoder-git 3.0.r0.gd21d551-2

Git Clone URL: https://aur.archlinux.org/astc-encoder-git.git (read-only, click to copy)
Package Base: astc-encoder-git
Description: A tool for compressing and decompressing images using the ASTC texture compression standard (git version)
Upstream URL: https://github.com/ARM-software/astc-encoder/
Licenses: Apache
Conflicts: astc-encoder
Provides: astc-encoder
Submitter: dariost
Maintainer: dbermond
Last Packager: dbermond
Votes: 3
Popularity: 0.73
First Submitted: 2016-04-08 11:47
Last Updated: 2021-06-04 13:20

Latest Comments

dbermond commented on 2021-02-22 20:30

@dariost Missing 'git' in makedepends. Without git installed, makepkg will show this error: ==> ERROR: Cannot find the git package needed to handle git sources.

Also, the pkgver() function needs to be updated, and mostly everything else, like license, depends, build() and package(). Need also to add provides=('astc-encoder') and conflicts=('astc-encoder').

You can see the base package astc-encoder as a reference for updating here.