Package Details: attica-git r527.6433b5d-1

Git Clone URL: https://aur.archlinux.org/attica-git.git (read-only)
Package Base: attica-git
Description: Qt5 library that implements the Open Collaboration Services API
Upstream URL: https://projects.kde.org/projects/frameworks/attica
Licenses: LGPL
Conflicts: attica-qt5
Provides: attica-qt5
Submitter: Sevenseven
Maintainer: Sevenseven
Last Packager: Sevenseven
Votes: 39
Popularity: 0.469732
First Submitted: 2010-11-16 07:28
Last Updated: 2015-08-12 07:21

Dependencies (4)

Required by (4)

Sources (1)

Latest Comments

Alad commented on 2016-06-12 12:46

Misses Maintainer tag. Also, avoid use of msg; if you want to inform on deleted file, use "rm -vrf" instead of "rm -rf".

https://bugs.archlinux.org/task/43502

blackwolf12333 commented on 2015-08-11 15:19

There is a space in the build function that prevents this package from building.

blackwolf12333 commented on 2015-08-11 15:19

There is a space in the build function that prevents this package from building.

cmake " ${srcdir}/attica"

^

firefox2501 commented on 2015-03-08 15:56

@berot3 - This is not an attica problem so it should not be listed here. You can most likely fix your issue by removing extra-cmake-modules and allowing the PGKBUILD in question to install the version that it thinks it needs.

Compiling plasma-desktop-git and all of its dependencies is labor intensive right now. Some dependent packages have build depends for extras-cmake-modules. Some dependent packages have build depends for extras-cmake-modules-git. Those two packages conflict with each other. Some dependent packages that have build depends for extra-cmake-modules actually require extras-cmake-modules-git because newer versions of the provided libraries are required. So building plasma-desktop-git will require you to swap between extras-cmake-modules and extras-cmake-modules-git as well as manually changing some PKG files to have build depends for extras-cmake-modules-git when the build fails with extras-cmake-modules.

The maintainer of this PKGBUILD has decided to list extra-cmake-modules-git as a build dependency to avoid this problem - the correct decision IMHO.

berot3 commented on 2015-02-26 19:54

I also had to install extra-cmake-modules-git in roder to compile plasma-desktop-git
why is that? I mean it already a dependency...

Sevenseven commented on 2015-02-24 05:14

I use extra-cmake-modules-git for avoid future problem.

firefox2501 commented on 2015-02-22 21:41

extras/extra-cmake-modules has been updated to 1.7.0.

attica-git appears to build correctly without requiring extra-cmake-modules-git

maz-1 commented on 2015-01-01 07:50

This package needs ecm 1.6.0.This is provided by extra-cmake-modules-git

anex commented on 2014-12-19 02:32


attica-git
v5.5.0.r1.g7c3c4e3-1
v5.5.0.rc1.r0.g6baad5c-1


yup

sl1pkn07 commented on 2014-12-18 13:56

version regresion

aur/attica-git v5.5.0.r1.g7c3c4e3-1 -> v5.5.0.rc1.r0.g6baad5c-1

5.5.0.r1.g7c3c4e3-1 is build today

greetings

All comments