Package Details: knewstuff-git 5.83.0_r1150.ge1d40ecb-1

Git Clone URL: https://aur.archlinux.org/knewstuff-git.git (read-only, click to copy)
Package Base: knewstuff-git
Description: Support for downloading application assets from the network
Upstream URL: https://community.kde.org/Frameworks
Licenses: LGPL
Conflicts: knewstuff
Provides: knewstuff
Submitter: ilpianista
Maintainer: IslandC0der (chaotic-aur)
Last Packager: IslandC0der
Votes: 16
Popularity: 0.000506
First Submitted: 2014-01-04 11:37 (UTC)
Last Updated: 2021-05-30 17:51 (UTC)

Required by (57)

Sources (1)

Latest Comments

IslandC0der commented on 2021-05-21 18:38 (UTC) (edited on 2021-05-21 18:40 (UTC) by IslandC0der)

It seems like all your -git packages are quite outdated; unfortunately, the only solution is to rebuild all of them :/

As a side note, I also use yay, and by default it will only update AUR packages if the PKGBUILD gets updated.

If you wanna make sure the updates show up whenever there's new upstream commits, consider running yay -Y --gendb

BujuArena commented on 2021-05-21 18:33 (UTC)

I can't update kconfig-git because of this error:

error: failed to commit transaction (conflicting files)
kconfig-git: /usr/lib/python2.7/site-packages/PyKF5/__init__.py exists in filesystem (owned by kguiaddons-git)
kconfig-git: /usr/lib/python3.9/site-packages/PyKF5/__init__.py exists in filesystem (owned by kguiaddons-git)

And updating kguiaddons-git doesn't fix that error, so I guess everything's tied in a knot and yay has no idea how to resolve it. Ultimately, I can't install knewstuff-git as a result still.

BujuArena commented on 2021-05-21 18:25 (UTC)

Trying to manually reinstall kcompletion-git gives me this build error:

CMake Error at CMakeLists.txt:39 (find_package):
  Could not find a configuration file for package "KF5Config" that is
  compatible with requested version "5.82.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5Config/KF5ConfigConfig.cmake, version: 5.79.0
    /usr/lib/cmake/KF5Config/KF5ConfigConfig.cmake, version: 5.79.0
    /lib64/cmake/KF5Config/KF5ConfigConfig.cmake, version: 5.79.0
    /lib/cmake/KF5Config/KF5ConfigConfig.cmake, version: 5.79.0

Something's pretty wonky about managing these -git packages with yay.

BujuArena commented on 2021-05-21 18:24 (UTC)

I manually reinstalled karchive-git just now and now I have a different build error:

CMake Error at CMakeLists.txt:28 (find_package):
  Could not find a configuration file for package "KF5Completion" that is
  compatible with requested version "5.82.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5Completion/KF5CompletionConfig.cmake, version: 5.79.0
    /usr/lib/cmake/KF5Completion/KF5CompletionConfig.cmake, version: 5.79.0
    /lib64/cmake/KF5Completion/KF5CompletionConfig.cmake, version: 5.79.0
    /lib/cmake/KF5Completion/KF5CompletionConfig.cmake, version: 5.79.0

I guess manually reinstalling karchive-git made it build later versions, and somehow these -git packages aren't getting updated, even though I manually run yay to update every day and yay -Syyu about once per week to make sure everything's updated. I guess I now have to manually reinstall kcompletion-git too.

BujuArena commented on 2021-05-21 18:18 (UTC)

I do have karchive-git installed. It's version .r451.g940558b-1. I use yay as an AUR helper.

IslandC0der commented on 2021-05-21 13:39 (UTC)

@BujuArena do you have karchive(-git) installed? If so, which version? Also, do you use an AUR helper?

BujuArena commented on 2021-05-20 21:46 (UTC) (edited on 2021-05-20 21:46 (UTC) by BujuArena)

Thanks for your effort! However, I tried clean-building and installing this again and I got the same build error as I commented yesterday. Does it help to know that I don't use KDE as my full desktop environment, but I use XFCE and I just use some programs that I like such as Kate and ksysguard?

IslandC0der commented on 2021-05-20 21:25 (UTC)

Thank you @BujuArena, should now be fixed :)

BujuArena commented on 2021-05-20 03:05 (UTC)

I'm getting this build error suddenly, starting today:

CMake Error at CMakeLists.txt:27 (find_package):
  Could not find a configuration file for package "KF5Archive" that is
  compatible with requested version "5.82.0".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/KF5Archive/KF5ArchiveConfig.cmake, version: 5.79.0
    /usr/lib/cmake/KF5Archive/KF5ArchiveConfig.cmake, version: 5.79.0
    /lib64/cmake/KF5Archive/KF5ArchiveConfig.cmake, version: 5.79.0
    /lib/cmake/KF5Archive/KF5ArchiveConfig.cmake, version: 5.79.0

IslandC0der commented on 2020-12-13 21:13 (UTC)

Fixed, thank you :)

duongdominhchau commented on 2020-12-10 20:17 (UTC)

Need kpackage-git as dependency.

g99 commented on 2018-06-11 14:31 (UTC)

nobody ever made any practical use of this. Misdocumented and broken for decades.

ahrs commented on 2017-06-12 14:26 (UTC)

This is missing python in its dependencies.

arojas commented on 2014-05-12 22:04 (UTC)

@jleclanche it's already un the dep chain

jleclanche commented on 2014-05-12 21:56 (UTC)

Missing dependency: attica-qt5