Package Details: calibre-web 0.6.21-2

Git Clone URL: https://aur.archlinux.org/calibre-web.git (read-only, click to copy)
Package Base: calibre-web
Description: Web app for browsing, reading and downloading eBooks stored in a Calibre database
Upstream URL: https://github.com/janeczku/calibre-web
Licenses: GPL3
Provides: calibre-web
Submitter: fryfrog
Maintainer: fryfrog (plenaerts)
Last Packager: fryfrog
Votes: 2
Popularity: 0.000207
First Submitted: 2021-11-29 04:13 (UTC)
Last Updated: 2024-02-13 17:45 (UTC)

Latest Comments

1 2 3 4 Next › Last »

cotsuka commented on 2024-05-26 23:13 (UTC)

@fryfrog I rebuilt python-pypdf2 and metadata editing seems to be working again. Oddly, I've reconfirmed python-sqlalchemy is installed but I'm still seeing the error message, although there doesn't seem to be any issues.

luciferin commented on 2024-05-25 12:17 (UTC) (edited on 2024-05-25 12:33 (UTC) by luciferin)

Is anyone else seeing these errors after the python3.12 upgrade?

[edit] disregard, I had an outdated version of python-pyzstd provided by the x86-64-v3 repo I was using.

fryfrog commented on 2024-05-24 16:33 (UTC)

@cotsuka: Yours says pypdf and sqlalchemy are missing, but they are depends already, maybe you need to rebuild them? Arch doesn't really have a way to use older versions in a reasonable way. Maybe a Docker image makes more sense?

cotsuka commented on 2024-05-24 14:29 (UTC)

I'm starting to see errors editing the "Description" metadata on certain books/PDFs. If I ensure dependencies are properly installed with their version constraints, then this seems to go away. Here's what I'm seeing in the logs:

[2024-05-23 09:41:26,772]  INFO {cps:168} *** "Flask-Babel" version does not meet the requirements. Should: <3.2.0, Found: 4.0.0, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "Flask-Login" version does not meet the requirements. Should: <0.6.3, Found: 0.6.3, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "PyPDF" version does not meet the requirements. Should: available, Found: Not available, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "requests" version does not meet the requirements. Should: <2.32.0, Found: 2.32.2, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "SQLAlchemy" version does not meet the requirements. Should: available, Found: Not available, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "tornado" version does not meet the requirements. Should: <6.4, Found: 6.4, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "lxml" version does not meet the requirements. Should: <5.0.0, Found: 5.2.2, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "flask-wtf" version does not meet the requirements. Should: <1.2.0, Found: 1.2.1, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "chardet" version does not meet the requirements. Should: <4.1.0, Found: 5.2.0, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "Flask-Limiter" version does not meet the requirements. Should: <3.5.0, Found: 3.7.0, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "gevent" version does not meet the requirements. Should: <24.0.0, Found: 24.2.1, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "greenlet" version does not meet the requirements. Should: <2.1.0, Found: 3.0.3, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "python-dateutil" version does not meet the requirements. Should: <2.9.0, Found: 2.9.0, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "py7zr" version does not meet the requirements. Should: <0.21.0, Found: 0.21.0, please consider installing required version ***
[2024-05-23 09:41:26,772]  INFO {cps:168} *** "jsonschema" version does not meet the requirements. Should: <4.20.0, Found: 4.21.1, please consider installing required version ***

fryfrog commented on 2024-02-13 17:45 (UTC)

@latipun, thanks for the report. Added!

latipun commented on 2024-02-13 14:22 (UTC)

Missing python-chardet dependency.

zynex commented on 2023-07-03 12:07 (UTC) (edited on 2023-07-03 12:10 (UTC) by zynex)

Something weird happened when I just upgraded the package. The service file was masked, and unable to unmask it. When i tried query the files from the package (pacman -Ql callibre-web), it was empty? Trying reinstalling it told me files already existed?

[EDIT] Fixed, issuing pikaur -S calibre-web --overwrite=* resolved it.

disastro commented on 2023-06-28 08:37 (UTC)

Missing python-cryptography dependency

plenaerts commented on 2023-05-15 16:06 (UTC)

Yes, it's basically ... this : https://wiki.archlinux.org/title/Python#Module_not_found_after_Python_version_update

And someone seems to have written a script to output a dependency tree if you have custom built dependencies in your installed AUR packages :-) https://bbs.archlinux.org/viewtopic.php?id=261309

zynex commented on 2023-05-05 22:28 (UTC) (edited on 2023-05-05 22:29 (UTC) by zynex)

@fryfrog That fixed it!

For others that run into same issue, create a text file with all dependencies and install it from that list. That will force a reinstallation of all packages. I my case; pikaur -S - < list.