Package Details: cloog 0.20.0-1

Git Clone URL: https://aur.archlinux.org/cloog.git (read-only)
Package Base: cloog
Description: Library that generates loops for scanning polyhedra
Upstream URL: http://www.bastoul.net/cloog/
Keywords: lib
Licenses: GPL
Submitter: haawda
Maintainer: aaronfischer (nougad)
Last Packager: aaronfischer
Votes: 65
Popularity: 1.337004
First Submitted: 2014-11-19 12:18
Last Updated: 2018-09-10 18:22

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Syllo commented on 2017-04-27 08:52

We released a new version at https://github.com/periscop/cloog
and CLooG can now use isl up to version 0.18 without breaking anything.

Please also add OpenScop as dependency (https://aur.archlinux.org/packages/osl/) because it will soon be mandatory. (--with-osl=system)

schimicata commented on 2016-11-07 15:18

Doesn't work this package also with isl-0.16-1 or what is the reason that isl15 is still listed as a dependency?

aaronfischer commented on 2016-08-12 20:38

@claudiocabral: thanks, I've added it to the arch array

claudiocabral commented on 2016-08-02 11:50

hi, this package builds fine in armv7h
could you please add it to the list of supported architectures?

DrMartinus commented on 2016-06-23 07:32

I have the same problem like apaatsio.

frankspace commented on 2016-05-27 04:54

For what it's worth, I tried upgrading isl to the latest version, 0.17.1, and that generated the same failure reported by GeorgeChao.

marcvangend commented on 2016-05-26 13:53

@apaatsio there seems to be some circular dependency. I solved it by simply uninstalling both packages (`sudo pacman -R cloog isl`) and then reinstalling cloog.

apaatsio commented on 2016-05-26 09:46

==> Continue installing isl15 ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==> y

loading packages...
resolving dependencies...
looking for conflicting packages...
:: isl15 and isl are in conflict. Remove isl? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: cloog: removing isl breaks dependency 'isl>=0.14'
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-antti
cp: overwrite '/tmp/yaourt-tmp-antti/isl15-0.15-1-x86_64.pkg.tar.xz'? y
==> Restart building cloog ? [y/N]


What's happening here? What should I do to fix the conflict between isl15 and isl?

aaronfischer commented on 2016-05-25 18:52

Thanks! I've added isl15 as the dependency.

Rynsin commented on 2016-05-24 20:10

Can confirm that you need to use isl15 to make this work (and modify the depend in the PKGBUILD) as of today.