Package Details: cnijfilter-mp620 3.00-4

Git Clone URL: https://aur.archlinux.org/cnijfilter-mp620.git (read-only, click to copy)
Package Base: cnijfilter-mp620
Description: Canon drivers for the MP610/MP620/MP630 printer/scanner with improved PPD files
Upstream URL: http://support-asia.canon-asia.com
Licenses: custom
Conflicts: cnijfilter-common, ppd-mp620-630
Submitter: mouse256
Maintainer: None
Last Packager: Bevan
Votes: 7
Popularity: 0.000000
First Submitted: 2010-09-02 18:58
Last Updated: 2015-07-08 12:15

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7

th-fr commented on 2012-05-12 08:28

Use cups-bjnp instead.

Anonymous comment on 2011-11-27 18:04

Still doesn't work... Same problem as described below. Maintainer is AWOL.

cippaciong commented on 2011-09-07 17:35

Hi, I used to install this package in order to print with my MP620 but on my last arch installation I get an error while building:
make[2]: Entering directory `/tmp/packerbuild-0/cnijfilter-mp620/cnijfilter-mp620/src/cnijfilter-common-2.80/backend'
Making all in src
make[3]: Entering directory `/tmp/packerbuild-0/cnijfilter-mp620/cnijfilter-mp620/src/cnijfilter-common-2.80/backend/src'
gcc -DHAVE_CONFIG_H -I. -I.. -O2 -Wall -MT cnij_backend_common.o -MD -MP -MF .deps/cnij_backend_common.Tpo -c -o cnij_backend_common.o cnij_backend_common.c
cnij_backend_common.c: In function ‘get_model_name’:
cnij_backend_common.c:192:2: error: unknown type name ‘ppd_file_t’
cnij_backend_common.c:196:2: warning: implicit declaration of function ‘ppdOpenFile’ [-Wimplicit-function-declaration]
cnij_backend_common.c:196:17: warning: assignment makes pointer from integer without a cast [enabled by default]
cnij_backend_common.c:198:23: error: request for member ‘product’ in something not a structure or union
cnij_backend_common.c:204:4: error: request for member ‘product’ in something not a structure or union
cnij_backend_common.c:218:3: warning: implicit declaration of function ‘ppdClose’ [-Wimplicit-function-declaration]
make[3]: *** [cnij_backend_common.o] Errore 1
make[3]: Leaving directory `/tmp/packerbuild-0/cnijfilter-mp620/cnijfilter-mp620/src/cnijfilter-common-2.80/backend/src'
make[2]: *** [all-recursive] Errore 1
make[2]: Leaving directory `/tmp/packerbuild-0/cnijfilter-mp620/cnijfilter-mp620/src/cnijfilter-common-2.80/backend'
make[1]: *** [all] Errore 2
make[1]: Leaving directory `/tmp/packerbuild-0/cnijfilter-mp620/cnijfilter-mp620/src/cnijfilter-common-2.80/backend'
make: *** [all] Errore 1
==> ERRORE: Si è verificato un errore in build().
L'operazione sta per essere interrotta...

I think that the problem is cnij_backend which shouldn't have the underscore starting from recent versions of cups.

Source= http://mp610.blogspot.com/2009/02/canon-printer-driver-and-cups-error.html

Furthermore, the .install file should be updated since the cups daemon is actually cupsd now.

Finally, on others computers I successfully installed the package but I'm not able to print (the printer is idle but doesn't gives signal of life when assigning a job); it shouldn't be a package error but I'm reporting it hoping in some help.

Thanks =)

Anonymous comment on 2010-12-11 19:02

Great work, works just nice, thanks. However, build needs to be adjusted for multilib - there are missing dependencies for lib32-libtiff and lib32-libpng. If you add those two packages manually, it builds just fine.

mouse256 commented on 2010-09-02 19:02

Thanks to the new multilib repository, this now works both on 32bit and 64bit!