Package Details: cozy-audiobooks 0.8.1-1

Git Clone URL: https://aur.archlinux.org/cozy-audiobooks.git (read-only, click to copy)
Package Base: cozy-audiobooks
Description: A modern audio book player for Linux using GTK+ 3.
Upstream URL: https://github.com/geigi/cozy
Keywords: audiobook gtk media player
Licenses: GPL3
Submitter: geigi
Maintainer: geigi (asm0dey)
Last Packager: geigi
Votes: 20
Popularity: 1.38
First Submitted: 2017-10-22 16:12
Last Updated: 2021-01-31 14:19

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

ValHue commented on 2020-05-23 06:57

@geigi With flatpak I get the same error. I don't get it, right now I'm blocked ...

geigi commented on 2020-05-21 08:46

@ValHue I just tried to reproduce your issue (but on another distro, I don't have a Arch installation currently). I've changed my system language to es_ES and generated the locales. Cozy started fine in Spanish. Then I tried the locales you've provided in your comment but those also just started fine.

Now I'm out of ideas... The language files also do look fine. Maybe it's a gettext issue, is there maybe an update for it? Another thing you can try is installing Cozy from flathub. It would be interesting whether this issue also exists there or only for the AUR packaged version.

ValHue commented on 2020-05-14 16:58

@geigi in /etc/locale.conf I have:

LANG=ca_ES.UTF-8@valencia

thinking that it was a locale problem and seeing that cozy doesn't have my language I have executed,

env LANG=es_ES.utf8 com.github.geigi.cozy

but it also fails at startup and gives the same error. Even with:

env LANG=en_US.utf8 com.github.geigi.cozy

Any idea?

*I have generated all the locations I have tried

geigi commented on 2020-05-09 23:09

@ValHue What's your system language?

ValHue commented on 2020-04-28 08:13

It doesn't work for me, it gives the following error:

['/usr/sbin/com.github.geigi.cozy']
handle exception
Traceback (most recent call last):
  File "/usr/sbin/com.github.geigi.cozy", line 170, in <module>
    main()
  File "/usr/sbin/com.github.geigi.cozy", line 139, in main
    application = Application()
  File "/usr/sbin/com.github.geigi.cozy", line 78, in __init__
    gettext.install('com.github.geigi.cozy', localedir)
  File "/usr/lib/python3.8/gettext.py", line 623, in install
    t = translation(domain, localedir, fallback=True, codeset=codeset)
  File "/usr/lib/python3.8/gettext.py", line 598, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python3.8/gettext.py", line 261, in __init__
    self._parse(fp)
  File "/usr/lib/python3.8/gettext.py", line 437, in _parse
    self.plural = c2py(plural)
  File "/usr/lib/python3.8/gettext.py", line 184, in c2py
    result, nexttok = _parse(_tokenize(plural))
  File "/usr/lib/python3.8/gettext.py", line 117, in _parse
    nexttok = next(tokens)
  File "/usr/lib/python3.8/gettext.py", line 94, in _tokenize
    raise ValueError('invalid token in plural form: %s' % value)
ValueError: invalid token in plural form: EXPRESSION

deadpyxel commented on 2020-03-02 17:18

Thanks for the reply, I'm using i3-gaps, so I"ll probably have to create a link manually.

geigi commented on 2020-03-01 18:16

@deadpyxel This is intended. I used cozy-audiobooks for the package name because cozy was already used by another package. Therefore I'm using the reverse DNS name suggested by Gnome: https://wiki.gnome.org/HowDoI/ChooseApplicationID Which desktop environment are you using? The application in the launcher should be named cozy as I provide a .desktop file.

deadpyxel commented on 2020-03-01 02:57

The package after installed for me doesn't show as cozy-audiobooks, but as com.github.geigi.cozy, is this intended?

geigi commented on 2020-02-28 07:38

Thanks for reporting, should be fixed now :)

shastry commented on 2020-02-28 03:31

SRCINFO and PKGBUILD have different pkgrel.

SRCINFO: 0.6.13-2 PKGBUILD: 0.6.13-1