Package Details: curecoin-qt-git v1.9.4.1.r19.gf570a26-1

Git Clone URL: https://aur.archlinux.org/curecoin-qt-git.git (read-only)
Package Base: curecoin-qt-git
Description: GUI client (wallet) for CureCoin cryptocurrency
Upstream URL: https://curecoin.net/
Licenses: MIT
Conflicts: curecoin-qt
Provides: curecoin-qt
Submitter: dark-saber
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 3
Popularity: 0.095825
First Submitted: 2017-11-04 17:30
Last Updated: 2018-04-13 18:46

Latest Comments

dark-saber commented on 2018-04-13 19:12

mthalmei:

Hi, thank you very much!

mthalmei commented on 2018-04-13 16:36

Hi ! I created a patch so the pkg version is correctly pulled from the git tag: https://pastebin.com/2ZKn5Xeu

dark-saber commented on 2018-03-30 06:08

afg984:

Fixed, thank you!

afg984 commented on 2018-03-29 18:03

git seems to be missing [1] from makedepends

[1] https://wiki.archlinux.org/index.php/VCS_package_guidelines

dark-saber commented on 2018-02-03 16:09

Aladar:

The problem appears to be here:

make: *** No rule to make target 'build/build.h', needed by 'build/version.o'.  Stop.

Why it happens is a different question.

Now, just to make sure it's not something trivial: 1. Have you tried to clean the SRCDIR and BUILDDIR?

2. You should have boost 1.66.0-1 and boost-libs 1.66.0-1 installed, no other boost libs such as boost-65-compat at the time of compilation.

3. You can probably try to build the package without any helpers, like this:

$ git clone https://aur.archlinux.org/curecoin-qt-git.git

$ cd curecoin-qt-git

$ makepkg -sif

and see if it makes any difference.

4. Could you please show your /etc/makepkg.conf, /etc/xdg/pacaur/config, and maybe ~/.config/pacaur/config if you have any custom settings there?

Aladar commented on 2018-02-03 12:14

Can't build the latest update. Not sure why, I can't see any errors, but...

https://pastebin.com/hQmYSURz

dark-saber commented on 2017-12-28 16:17

olivier.gareau: Added it, thanks!

olivier.gareau commented on 2017-12-28 15:24

Please add package qt5-tools as a dependency, it is needed or else build fails with error "lrelease: command not found". Thanks!