Package Details: cyrus-imapd 3.8.3-1

Git Clone URL: (read-only, click to copy)
Package Base: cyrus-imapd
Description: An email, contacts and calendar server
Upstream URL:
Licenses: BSD-Attribution-HPND-disclaimer
Provides: imap-server, pop3-server
Submitter: ryanc
Maintainer: J5lx
Last Packager: J5lx
Votes: 27
Popularity: 0.000269
First Submitted: 2007-10-14 08:22 (UTC)
Last Updated: 2024-06-06 14:24 (UTC)

Latest Comments

1 2 3 4 5 6 .. 12 Next › Last »

zork commented on 2023-04-27 14:04 (UTC) (edited on 2023-04-27 14:19 (UTC) by zork)

a patch:

Reported as
--- package.pristine/docsrc/ 2022-12-12 03:05:16.000000000 +0100
+++ package.patched/docsrc/  2023-04-27 15:49:52.022327117 +0200
@@ -527,8 +527,8 @@
# XXX handlers here, except that these urls require expanding the version string
# XXX twice, and the sphinx extlinks thingy currently only supports a single %s
extlinks = {
-        'draft':('', ''),
-        'issue':('', 'Issue #'),
+        'draft':('', None),
+        'issue':('', 'Issue #%s'),

zork commented on 2023-04-26 21:15 (UTC)

I have problems with docs:

/home/zork/.cache/yay/cyrus-imapd/src/cyrus-imapd-3.6.0/docsrc/imap/download/installation/http/caldav.rst:377: ERROR: Unknown target name: "cyrus-timezones package<>".

Exception occurred:
  File "/usr/lib/python3.10/site-packages/sphinx/ext/", line 103, in role
    title = caption % part
TypeError: not all arguments converted during string formatting
The full traceback has been saved in /tmp/sphinx-err-i4hazn1q.log, if you want to report the issue to the developers.

Archange commented on 2023-01-11 01:57 (UTC)

I’ve added this package to [community-testing]. Two import differences to notes: – I’m not rebuilding docs, so the additional man pages are not available ; – thanks to @loqs, I’m building against pcre2 to allow as-needed to work. It should normally be fine (all unit tests passed), but it has not been tested in a real environment.

I’ll watch comments here in case there is anything wrong with the provided package, and will move it to [community] after ~2 weeks.

J5lx commented on 2022-12-26 01:49 (UTC)

I’ve just pushed the update to 3.6.0. There are some notable changes in this version, so please make sure to read the release notes and the upgrading instructions carefully before upgrading. In particular, if you are behind on updates and still running a version older than 3.4.4, please don’t upgrade to 3.6 directly.

J5lx commented on 2022-02-03 21:38 (UTC)

I’ve applied your workaround as part of the 3.4.3 update. Thanks for reporting!

mappy73 commented on 2022-01-19 15:55 (UTC) (edited on 2022-01-19 15:58 (UTC) by mappy73)

I ran into a bug that has been reported since 3.4.1 and still open: This bug causes UID SEARCH imap command to either return bogus/nothing or crash the server process, when using squat as the search engine. Not all clients are affected, but some use UID SEARCH extensively and won't download any messages (K-9 mail on Android is an example). There is a workaround: add

    # Work around Cyrus bug #3562
    export CFLAGS="${CFLAGS} -fno-toplevel-reorder"

to build()

jjulian commented on 2021-05-06 00:35 (UTC)

I successfully built 3.4.0. The only changes I had to make besides the pkgver and sha512sum changes was that I could now remove the sphinx3.patch.

J5lx commented on 2020-08-20 10:12 (UTC) (edited on 2020-08-23 10:52 (UTC) by J5lx)

All this might be considerably more manageable if the documentation […] were split off into its own package.

I’ll consider it in the future. For now I’ve stuck with the current method, since I already had a patch ready. Sorry for the late update.

Edit: Unfortunately it’s not that easy after all. I just remembered that the main reason for why those documentation dependencies are needed is not actually for the -docs package, but for some of the manpages in the “main” package, which I’d rather not split out into a completely separate package.

pronet commented on 2020-08-18 15:39 (UTC) (edited on 2020-08-18 15:40 (UTC) by pronet)

If you must use -d to get it to work something else is wrong. Fix that first. You cannot skip package dependencys and expect it to compile correctly. That is why they have package dependencys so everything needed is there. Apparently python-sphinx-2 is not installed correctly. Did you also install it with -d ? Try installing python-sphinx-2 with "yay". It will find all the needed dependencys when it builds the package Also you dont need to have old versions installed to use downgrade. downgrade fetches them remotely as shown in my previous post.

zork commented on 2020-08-18 10:17 (UTC)

I cannot use "downgrade" aur package, I do not have older python-sphinx packages in pacman cache. I build python-sphinx-2 from AUR and it worked with makepkg -d and original PKGBUILD (3.0.13). For 3.2.2 I have an error - see my earlier comment.