Package Details: discourse 2.6.2-1

Git Clone URL: https://aur.archlinux.org/discourse.git (read-only, click to copy)
Package Base: discourse
Description: A simple, flat forum, where replies flow down the page in a line
Upstream URL: https://www.discourse.org/
Keywords: forum rails
Licenses: GPL
Submitter: rumpelsepp
Maintainer: ljmf00
Last Packager: ljmf00
Votes: 4
Popularity: 0.000001
First Submitted: 2014-11-17 08:32 (UTC)
Last Updated: 2021-04-02 03:05 (UTC)

Pinned Comments

Latest Comments

acerix commented on 2021-12-11 20:39 (UTC)

It seems Ruby 3 is not compatible, I get:

redis-namespace-1.8.0 requires ruby version ~> 2.4, which is incompatible with the current version, ruby 3.0.3p157

I was able to build after installing rvm and running rvm install 2.7.

grandchild commented on 2021-05-21 18:39 (UTC)

Doesn't install with ruby version 3+. I have ruby2.7 installed, how do I have that picked up instead?

acxz commented on 2020-08-03 01:57 (UTC)

Hey guys trying to test a local discourse, I installed successfully but when attempting to run the command in the post_install()

I am getting the following error:

rake aborted!
Errno::EACCES: Permission denied @ dir_s_mkdir - /usr/share/webapps/discourse/app/assets/javascripts/plugins
/usr/share/webapps/discourse/lib/plugin/instance.rb:328:in `ensure_directory'
/usr/share/webapps/discourse/lib/plugin/instance.rb:599:in `activate!'
lib/discourse.rb:224:in `block in activate_plugins!'
lib/discourse.rb:221:in `each'
lib/discourse.rb:221:in `activate_plugins!'
/usr/share/webapps/discourse/config/application.rb:302:in `block in <class:Application>'
/usr/share/webapps/discourse/lib/plugin_initialization_guard.rb:5:in `plugin_initialization_guard'
/usr/share/webapps/discourse/config/application.rb:301:in `<class:Application>'
/usr/share/webapps/discourse/config/application.rb:69:in `<module:Discourse>'
/usr/share/webapps/discourse/config/application.rb:68:in `<top (required)>'
/usr/share/webapps/discourse/Rakefile:7:in `require'
/usr/share/webapps/discourse/Rakefile:7:in `<top (required)>'
/usr/share/webapps/discourse/vendor/bundle/ruby/2.7.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
/usr/bin/bundle:23:in `load'
/usr/bin/bundle:23:in `<main>'
(See full trace by running task with --trace)

Also I could not find the file in this line: https://aur.archlinux.org/cgit/aur.git/tree/discourse.install?h=discourse#n14

Thank you!

rican-linux commented on 2017-05-08 03:48 (UTC)

It is already broken. Replacing it with uglify-js works. Also gem crashes when trying to install json 1.8.3.

jnbek commented on 2017-04-16 20:49 (UTC)

you'll want to update your makedeps... nodejs-uglify-js is a duplicate for the Community pkg uglify-js and has a pending deletion request which will likely break this pkgbuild. Just a heads up.

rumpelsepp commented on 2016-08-03 13:24 (UTC)

I still use this PKGBUILD for my custom discourse install and it still works. But I can't reproduce any install errors because I am migrating to FreeBSD on the server side. In other words, I will orphan this and hopefully someone can fix it again.

lifehome commented on 2016-07-23 09:46 (UTC)

Bumped version number, however after the install it cannot start.

Rivalo commented on 2016-04-24 20:51 (UTC)

Outdated, unavailable dependencies. Instructions that should make it run are outdated and nonfunctional. In other words: avoid.

rumpelsepp commented on 2015-12-27 10:03 (UTC)

you just have to bump the version number; it builds flawlessly.

HLFH commented on 2015-12-16 12:38 (UTC)

Any updates??

commented on 2015-07-21 12:53 (UTC)

@rumpelsepp: No, all deps are installed.

commented on 2015-07-21 12:37 (UTC)

Hmm, okay could install it on the locale machine but not on the remote machine. You were maybe right about the missing deps. Will check that.

commented on 2015-07-21 11:40 (UTC)

@rumpelsepp: Just checked every single one. All deps are installed. Seems to be a problem with ruby-bundler.

rumpelsepp commented on 2015-07-21 08:57 (UTC)

@natepad: Maybe a missing dep?

commented on 2015-07-21 08:49 (UTC)

I get the following error: http://imgur.com/ceKod72

rumpelsepp commented on 2015-07-07 08:02 (UTC)

@thisischrys: yes. I will update it.

thisischrys commented on 2015-06-19 08:15 (UTC)

shouldn't redis be listed as an optional dependency?

rumpelsepp commented on 2015-06-19 07:11 (UTC)

That makes sense... I could update the legacy AUR package as well. Sry.

thisischrys commented on 2015-06-19 02:39 (UTC)

Had the same problem with pacaur and makepkg, until I figured out I'm supposed to use aur4 now. aur package won't build. I guess it's unavoidable for now.

rumpelsepp commented on 2015-06-13 15:20 (UTC)

Cannot reproduce: ==> Starting package()... -> Creating directories and symlinks... -> Install and symlink config files... -> Installing license, documentation and example files... -> Installing systemd service files... -> Installing systemd tmpfiles.d... -> Installing logrotate... ==> Tidying install... -> Purging unwanted files... -> Removing libtool files... -> Removing static library files... -> Compressing man and info pages... -> Stripping unneeded symbols from binaries and libraries... ==> Creating package "discourse"... -> Generating .PKGINFO file... -> Adding install file... -> Generating .MTREE file... -> Compressing package... ==> Leaving fakeroot environment. ==> Finished making: discourse 1.3.1-1 (Sa 13. Jun 17:18:33 CEST 2015) Please try pacaur (or plain makepkg) instead of yaourt. It seems that the prepare() function is being skipped…

thisischrys commented on 2015-06-12 00:46 (UTC)

same problem cp: cannot stat ‘config/discourse_quickstart.conf’: No such file or directory building it with yaourt, I'll try manually JIC also 1.3.2 is out

rumpelsepp commented on 2015-06-11 18:48 (UTC)

I think it is better to provide the stable versions (atm 1.3.1). They are moving quite fast, but they are maintaining stable versions as well- The version should build, because there is a patch applied which fixes your problem: https://aur4.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=discourse#n86 Did you skip the prepare() function?

PetaByteBoy commented on 2015-06-11 15:21 (UTC)

1.4.0 is going beta already also it is not building: ==> Starting package()... -> Creating directories and symlinks... -> Install and symlink config files... cp: cannot stat 'config/discourse_quickstart.conf': No such file or directory ==> ERROR: A failure occurred in package().

rumpelsepp commented on 2015-03-29 08:52 (UTC)

Just updated: https://gitlab.sevenbyte.org/rumpelsepp/aur_packages/commit/3922ed54b56b48d8e341a538fdba0c6d454c7b82

wertha commented on 2015-02-25 07:58 (UTC)

version 1.3.0.beta1 has been released. Please update