Package Details: discourse 2.6.2-1

Git Clone URL: (read-only, click to copy)
Package Base: discourse
Description: A simple, flat forum, where replies flow down the page in a line
Upstream URL:
Keywords: forum rails
Licenses: GPL
Submitter: rumpelsepp
Maintainer: None
Last Packager: ljmf00
Votes: 5
Popularity: 0.000097
First Submitted: 2014-11-17 08:32 (UTC)
Last Updated: 2021-04-02 03:05 (UTC)

Pinned Comments

Latest Comments

1 2 3 4 Next › Last »

Kunda commented on 2024-03-15 13:05 (UTC)

3.2.0 is out

bquast commented on 2023-01-24 20:00 (UTC) (edited on 2023-01-24 20:00 (UTC) by bquast)

version 3 is out, this fixes the redis-namespace issue below.

Download a snapshot of the package, unzip, in PKGBUILD update version from 2.6.2 to 3.0.0


rename "COPYRIGHT.txt" to "" (also in the PKGBUILD file)

acerix commented on 2021-12-11 20:39 (UTC)

It seems Ruby 3 is not compatible, I get:

redis-namespace-1.8.0 requires ruby version ~> 2.4, which is incompatible with the current version, ruby 3.0.3p157

I was able to build after installing rvm and running rvm install 2.7.

grandchild commented on 2021-05-21 18:39 (UTC)

Doesn't install with ruby version 3+. I have ruby2.7 installed, how do I have that picked up instead?

acxz commented on 2020-08-03 01:57 (UTC)

Hey guys trying to test a local discourse, I installed successfully but when attempting to run the command in the post_install()

I am getting the following error:

rake aborted!
Errno::EACCES: Permission denied @ dir_s_mkdir - /usr/share/webapps/discourse/app/assets/javascripts/plugins
/usr/share/webapps/discourse/lib/plugin/instance.rb:328:in `ensure_directory'
/usr/share/webapps/discourse/lib/plugin/instance.rb:599:in `activate!'
lib/discourse.rb:224:in `block in activate_plugins!'
lib/discourse.rb:221:in `each'
lib/discourse.rb:221:in `activate_plugins!'
/usr/share/webapps/discourse/config/application.rb:302:in `block in <class:Application>'
/usr/share/webapps/discourse/lib/plugin_initialization_guard.rb:5:in `plugin_initialization_guard'
/usr/share/webapps/discourse/config/application.rb:301:in `<class:Application>'
/usr/share/webapps/discourse/config/application.rb:69:in `<module:Discourse>'
/usr/share/webapps/discourse/config/application.rb:68:in `<top (required)>'
/usr/share/webapps/discourse/Rakefile:7:in `require'
/usr/share/webapps/discourse/Rakefile:7:in `<top (required)>'
/usr/share/webapps/discourse/vendor/bundle/ruby/2.7.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
/usr/bin/bundle:23:in `load'
/usr/bin/bundle:23:in `<main>'
(See full trace by running task with --trace)

Also I could not find the file in this line:

Thank you!

rican-linux commented on 2017-05-08 03:48 (UTC)

It is already broken. Replacing it with uglify-js works. Also gem crashes when trying to install json 1.8.3.

jnbek commented on 2017-04-16 20:49 (UTC)

you'll want to update your makedeps... nodejs-uglify-js is a duplicate for the Community pkg uglify-js and has a pending deletion request which will likely break this pkgbuild. Just a heads up.

rumpelsepp commented on 2016-08-03 13:24 (UTC)

I still use this PKGBUILD for my custom discourse install and it still works. But I can't reproduce any install errors because I am migrating to FreeBSD on the server side. In other words, I will orphan this and hopefully someone can fix it again.