Package Details: edx-downloader-git 0.1.12.r2.g1009c18-1

Git Clone URL: (read-only, click to copy)
Package Base: edx-downloader-git
Description: A simple tool to download video lectures from
Upstream URL:
Keywords: edx
Licenses: LGPL3
Conflicts: edx-downloader
Provides: edx-downloader
Submitter: enrico.bacis
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 6
Popularity: 0.000000
First Submitted: 2015-01-15 19:58 (UTC)
Last Updated: 2021-09-12 13:27 (UTC)

Latest Comments

1 2 Next › Last »

thLnoa6r4l commented on 2016-04-13 10:39 (UTC)

dark-saber: Thank you for the link, the recent version fixed this issue.

dark-saber commented on 2016-04-12 08:20 (UTC)

thLnoa6r4l: The similar bug ( / was recently fixed in upstream: Have you tried to update edx-downloader-git to most recent version? And how do you execute edx-dl? I'm using the command: edx-dl -u -p "p^S5w0Rd" -x edx, and it runs without problems.

thLnoa6r4l commented on 2016-04-11 20:50 (UTC)

anybody facing this issue when trying to download any MOOC? Traceback (most recent call last): File "/usr/bin/edx-dl", line 9, in <module> load_entry_point('edx-dl==0.0', 'console_scripts', 'edx-dl')() File "/usr/lib/python3.5/site-packages/edx_dl/", line 970, in main all_units = extractor(all_urls, headers) File "/usr/lib/python3.5/site-packages/edx_dl/", line 434, in extract_all_units_in_parallel units =, urls) File "/usr/lib/python3.5/multiprocessing/", line 260, in map return self._map_async(func, iterable, mapstar, chunksize).get() File "/usr/lib/python3.5/multiprocessing/", line 608, in get raise self._value File "/usr/lib/python3.5/multiprocessing/", line 119, in worker result = (True, func(*args, **kwds)) File "/usr/lib/python3.5/multiprocessing/", line 44, in mapstar return list(map(*args)) File "/usr/lib/python3.5/site-packages/edx_dl/", line 405, in extract_units units = page_extractor.extract_units_from_html(page, BASE_URL) File "/usr/lib/python3.5/site-packages/edx_dl/", line 100, in extract_units_from_html unit = self.extract_unit(unit_html, BASE_URL) File "/usr/lib/python3.5/site-packages/edx_dl/", line 272, in extract_unit metadata = json.loads(html_parser.HTMLParser().unescape(match_metadata)) File "/usr/lib/python3.5/json/", line 319, in loads return _default_decoder.decode(s) File "/usr/lib/python3.5/json/", line 339, in decode obj, end = self.raw_decode(s, idx=_w(s, 0).end()) File "/usr/lib/python3.5/json/", line 355, in raw_decode obj, end = self.scan_once(s, idx) json.decoder.JSONDecodeError: Expecting property name enclosed in double quotes: line 1 column 2 (char 1)

enrico.bacis commented on 2016-03-29 15:20 (UTC)

Unfortunately at the moment I don't have time to follow this, but if you need to update the PKGBUILD tell me ;)

thLnoa6r4l commented on 2016-03-29 15:14 (UTC)

dark-saber: how did you solve the versioning problem with html5lib (0.9999999 <=> 1.0b2)? (...) pkg_resources.ContextualVersionConflict: (html5lib 0.9999999 (/usr/lib/python3.5/site-packages), Requirement.parse('html5lib>=1.0b2'), {'edx-dl'})

thLnoa6r4l commented on 2016-03-26 09:56 (UTC) (edited on 2016-03-26 10:37 (UTC) by thLnoa6r4l)

dark-saber: Thank you, removing the patch has also solved my problem. Thank you for the fast reply.

dark-saber commented on 2016-03-25 19:21 (UTC)

thLnoa6r4l: I don't have this problem on my system, but I think, that that this problem may be related to core.autocrlf Git attribute. req-html5lib.patch file has Unix line endings, but, maybe, requirements.txt in edx_dl repo has Windows line endings and Git doesn't convert them when cloning. Anyway, I've tried to remove that patch and I don't have any issues with html5lib versioning I've ran into previously. Could you please test, does it build now without that patch?

thLnoa6r4l commented on 2016-03-25 11:18 (UTC)

I have trouble building this package. ==> Continue building edx-downloader-git ? [Y/n] ==> -------------------------------------------- ==> ==> Building and installing package ==> Making package: edx-downloader-git r567.64ecd9a-1 (Fri Mar 25 12:06:16 CET 2016) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Cloning edx-dl git repo... Cloning into bare repository '/tmp/yaourt-tmp-frettchen/aur-edx-downloader-git/edx-dl'... remote: Counting objects: 2377, done. remote: Total 2377 (delta 0), reused 0 (delta 0), pack-reused 2377 Receiving objects: 100% (2377/2377), 36.81 MiB | 1.35 MiB/s, done. Resolving deltas: 100% (1305/1305), done. Checking connectivity... done. -> Found req-html5lib.patch ==> Validating source files with sha256sums... edx-dl ... Skipped req-html5lib.patch ... Passed ==> Extracting sources... -> Creating working copy of edx-dl git repo... Cloning into 'edx-dl'... done. Switched to a new branch 'makepkg' ==> Starting prepare()... patching file requirements.txt Hunk #1 FAILED at 1 (different line endings). 1 out of 1 hunk FAILED -- saving rejects to file requirements.txt.rej ==> ERROR: A failure occurred in prepare(). Aborting... ==> ERROR: Makepkg was unable to build edx-downloader-git. Any idea what went wrong here?

bhrgunatha commented on 2015-10-16 10:38 (UTC) (edited on 2015-10-16 12:41 (UTC) by bhrgunatha)

Well it works and that's what most important (for me at least.) Thanks. > html5lib double-versioning is a mess, 0.9999999 and 1.0b8 are in fact the same Yes, Schrödinger versioning just causes headaches. If the maintainers want to have pip install it, just release it already.

dark-saber commented on 2015-10-12 07:44 (UTC)

bhrgunatha: Thank you! I've made a dirty fix which should make it possible to use the package from now on. I think it will remain till html5lib-1.0x would be in Arch or upstream requirements.txt would be changed. html5lib double-versioning is a mess, 0.9999999 and 1.0b8 are in fact the same, but packaging and requirement-checking versioning conventions are somehow different.