Package Details: emacs-magit-popup 2.12.5-2

Git Clone URL: https://aur.archlinux.org/emacs-magit-popup.git (read-only)
Package Base: emacs-magit-popup
Description: A generic interface for toggling switches and setting options and then invoking an Emacs command which does something with these arguments
Upstream URL: http://github.com/magit/magit-popup
Licenses: GPL3
Conflicts: emacs-magit<=2.11.0
Provides: emacs-magit-popup
Submitter: esben
Maintainer: esben
Last Packager: esben
Votes: 1
Popularity: 0.005805
First Submitted: 2017-12-15 20:28
Last Updated: 2019-01-14 08:22

Latest Comments

esben commented on 2019-01-14 08:23

Pushed fixed .SRCINFO and workaround for emacs-nox problem.

yar commented on 2019-01-12 19:09

Also, please remove the version from the emacs dep, it doesn't work with packages that provide emacs (like emacs-nox). See: https://bugs.archlinux.org/task/60763

yar commented on 2019-01-12 18:59

You should run mksrcinfo again, because the pkgrel doesn't match

esben commented on 2018-08-29 18:11

Fix applied. Thanks @donpicoro

jgalar commented on 2018-08-02 19:45

@donpicoro

I can confirm your fix works, thanks!

donpicoro commented on 2018-08-02 14:06

@C5OK5Y: I noticed there is a suspicious line, just changed it

diff --git a/PKGBUILD b/PKGBUILD index bbe43ed..be3e681 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -20,7 +20,7 @@ md5sums=('SKIP') build() { cd "$srcdir/${_github_repo}" unset EMACS - make LOAD_PATH="-L /usr/share/emacs/site-lisp/dash" \ + make LOAD_PATH="-L /usr/share/emacs/site-lisp" \ lisp info }

and it compiles.

C5OK5Y commented on 2018-06-08 18:38

Building this package with makepkg seems to fail with the following error:

==> Starting build()...
Compiling magit-popup.el
Generating magit-popup-autoloads.el
Generating magit-popup.info

In toplevel form:
magit-popup.el:53:1:Error: Cannot open load file: No such file or directory, dash
make: *** [Makefile:56: magit-popup.elc] Error 1
make: *** Waiting for unfinished jobs....
==> ERROR: A failure occurred in build().
    Aborting...

I have emacs 26.1 and emacs-dash 2.14.1-2 installed.

donpicoro commented on 2018-05-03 13:45

Hej,

There is a new emacs-dash (2.14.1-2). I wonder whether the fix emacs-dash=2.13.0 requirement is still needed?

Cheers,

/Pico