Package Details: emacs-git 30.0.50.169253-1

Git Clone URL: https://aur.archlinux.org/emacs-git.git (read-only, click to copy)
Package Base: emacs-git
Description: GNU Emacs. Development master branch.
Upstream URL: http://www.gnu.org/software/emacs/
Keywords: development editor IDE text
Licenses: GPL3
Conflicts: emacs
Provides: emacs
Submitter: toropisco
Maintainer: toropisco
Last Packager: toropisco
Votes: 104
Popularity: 0.000335
First Submitted: 2014-01-05 02:05 (UTC)
Last Updated: 2023-10-14 18:36 (UTC)

Required by (314)

Sources (2)

Pinned Comments

toropisco commented on 2017-06-30 19:14 (UTC) (edited on 2022-05-15 13:26 (UTC) by toropisco)

This PKGBUILD is a work in progress. If you find PACKAGING bugs, please let me know ASAP.

Upstream bugs are to be reported upstream. Check out the emacs-devel archives to confirm if this is an already known bug. In fact... Why are you not subscribed to emacs-devel?. Also check the emacs-bug-tracker archives.

Reporting bugs: Write to the Emacs Bug Tracker and report it there. Or, better yet, use the debbugs client included with the text editor. You will find instructions at https://debbugs.gnu.org/. Good luck!

If you confirm it is a packaging bug, you are welcome to report it here.

Yaourt and other automated tools users BEWARE! This PKGBUILD is written with hand updating in mind and I won't fix bugs arising from such use. Besides, cloning the same repository time and time again from a non-profit such as the GNU Project/FSF gives out a very low image of you.

Latest Comments

1 2 3 4 5 6 .. 39 Next › Last »

toropisco commented on 2024-07-02 22:36 (UTC)

@lyra. You forgot to install the metapackage base-devel.

lyra commented on 2024-07-02 21:28 (UTC)

I've encountered an error:

configure: error: You do not seem to have makeinfo >= 4.13, and your
source tree does not seem to have pre-built manuals in the 'info' directory.

And it resolved with installing core/texinfo package. Maybe it needs to be added into Dependencies?

toropisco commented on 2023-12-03 21:08 (UTC)

@utkarsh don't pay attention. Upstream mistakenly hardcoded its configuration scripts to look for a very old version of sysprof. The correct one required by glib2 and gtk is pulled in as an implicit dependency.

In other words, upstream bugs, complains to upstream. :-)

utkarsh commented on 2023-12-03 13:16 (UTC)

Hi @toropisco,

I'm getting the following warnings when building the package:

cc1: warning: /usr/include/sysprof-4: No such file or directory [-Wmissing-include-dirs]

Any guesses?

Nealsid commented on 2023-05-13 20:28 (UTC)

Yes, sir.

toropisco commented on 2023-05-13 20:11 (UTC)

Nealsid. Instead of polluting this package forum thread section with low quality comments, your fellow AUR users and myself, the maintainer who actually added support for pgtk three years ago, would appreciate if your read makepkg's man page and made yourself familiar with the -p flag.

toropisco commented on 2023-05-13 20:11 (UTC)

Nealsid. Instead of polluting this package forum thread section with low quality comments, your fellow AUR users and myself, the maintainer who actually added support for pgtk three years ago, would appreciate if your read makepkg's man page and made yourself familiar with the -p flag.

Nealsid commented on 2023-05-09 22:47 (UTC) (edited on 2023-05-09 22:47 (UTC) by Nealsid)

If anyone wants to build with Wayland support, I had to make the following patch (but I'm not sure how the package version difference snuck in there)

diff --git a/PKGBUILD b/PKGBUILD
index 0b35e4a..c4379f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,12 +50,12 @@ GPM=              # Mouse support in Linux console using gpmd.

 NOTKIT=           # Use no toolkit widgets. Like B&W Twm (001d sk00l).
                   # Bitmap fonts only, 1337!
-               
-PGTK=             # Use native GTK3 build. Supports Wayland, yay! Still
+
+PGTK="YES"        # Use native GTK3 build. Supports Wayland, yay! Still
                   # has some problems if running under Xorg. Remember,
                   # this is my personal build file!

-GTK3="YES"        # GTK3 old windowing interface.
+GTK3=             # GTK3 old windowing interface.

 LUCID=            # Use the lucid, a.k.a athena, toolkit. Like XEmacs, sorta.
                   #
@@ -93,7 +93,7 @@ if [[ $CLI == "YES" ]] ; then
 else
   pkgname="emacs-git"
 fi
-pkgver=30.0.50.165856
+pkgver=30.0.50.166196
 pkgrel=1
 pkgdesc="GNU Emacs. Development master branch."
 arch=('x86_64')

snackattack commented on 2023-02-16 23:22 (UTC) (edited on 2023-02-17 14:11 (UTC) by snackattack)

You are soooo GenZ that vou can see beyond your navel.

Second, yes it seems there's a bug that seems to be relatively recent. I've already fixed it in my repository, but... Should I give it to you today, you entitled brat?

This is really inappropriate, and violates Arch code of conduct, see the sections on respect, flaming, and ranting.

https://terms.archlinux.org/docs/code-of-conduct/

ykelvis commented on 2023-02-16 01:45 (UTC)

in the case of replace, i think it is indeed misused. it is used to replace obsolete packages, emacs obviously is not.1 as said in wiki, alternative package in aur should use conflict and provide instead of replace.

if a user has emacs installed and is using a repo that has this package prebuilt, when doing a Syu there would be prompt like "Replace emacs with emacs-git?[Y/n]", because replace makes pacman think emacs is obsolete. the more resonable behaviour should be prompting conflict issus when user explicitly wants to install emacs-git. this happened in our repo, but if the user only use aur and official repos, that would be fine. 2