Package Details: emacs-with-editor-git 2.7.3.r0.ad5bb005ed3a-1

Git Clone URL: https://aur.archlinux.org/emacs-with-editor-git.git (read-only)
Package Base: emacs-with-editor-git
Description: Use the Emacsclient as the of child processes
Upstream URL: http://github.com/magit/with-editor
Licenses: GPL3
Conflicts: emacs-with-editor
Provides: emacs-with-editor
Submitter: esben
Maintainer: esben
Last Packager: esben
Votes: 2
Popularity: 0.000001
First Submitted: 2016-01-31 07:59
Last Updated: 2018-06-07 11:57

Required by (3)

Sources (1)

Latest Comments

esben commented on 2017-09-30 14:23

I implemented "unset EMACS". Let me know if there are further problems.

WhittlesJr commented on 2017-07-31 19:36

I had a problem with my bash environment having the EMACS variable set to the version of emacs ('25.2.1,term:0.96' in my case) rather than the "emacs" command.

The Makefile in with-editor doesn't override EMACS if it's already set, but substitutes that variable in for its invocation of emacs. So I got syntax errors when it ran the build.

So it might be helpful to do "unset EMACS" at the top of your build() step, maybe even setting it back to what it was before afterward. That fixed the issue for me.

Although I understand if you think this is too niche of a case. I honestly don't know where that var came from. (I use a version of multi-term.el for terminal emulation, could be that?)

esben commented on 2017-02-25 15:24

Fixed, thanks.

helasraizam commented on 2017-02-25 08:59

Installation fails with "error: target not found: emacs-dash=2.12.1". In any case with-editor.el seems to be okay with emacs-dash>=2.12.1 (it lists 2.13.0), so would it be okay to depend on emacs-dash>=2.12.1 (or perhaps >=2.13.0)?