Package Details: eternallands 1.9.6.1-1

Git Clone URL: https://aur.archlinux.org/eternallands.git (read-only, click to copy)
Package Base: eternallands
Description: A free 3D MMORPG game with thousands of on-line players
Upstream URL: http://www.eternal-lands.com/
Licenses: custom
Submitter: encelo
Maintainer: encelo
Last Packager: encelo
Votes: 2
Popularity: 0.000023
First Submitted: 2020-09-19 01:18 (UTC)
Last Updated: 2022-04-08 10:47 (UTC)

Latest Comments

Leonardo19 commented on 2022-04-09 10:43 (UTC)

You are right: the problem with my mesa driver. Sorry.

encelo commented on 2022-04-09 10:21 (UTC)

The game works fine on my computer, I don't think the message you received while compiling is related in any way.

It seems a problem with creating the OpenGL context. Maybe the game doesn't support your GPU + drive combination? What are your specs?

Leonardo19 commented on 2022-04-09 10:16 (UTC)

While compilling I received the message that the package contains a link to '$srcdir' directory.

As result: [/home/myuser/eternallands/src/Eternal-Lands-1.9.6.1/gl_init.c:310] Failed to create game window, going to exit.

encelo commented on 2022-04-08 10:50 (UTC)

Updated client, data and sounds to 1.9.6.1. Thanks @pjbroad!

pjbroad commented on 2022-04-07 23:57 (UTC)

You might be interested in a new stable release containing a few bug fixes. https://github.com/raduprv/Eternal-Lands/releases/tag/1.9.6.1

encelo commented on 2021-12-24 18:15 (UTC)

Updated client and data to 1.9.6.0

  • Added openssl to the depends array

encelo commented on 2021-07-27 21:30 (UTC) (edited on 2021-07-27 21:31 (UTC) by encelo)

Using CMake to build the game

  • Removed pkgconf from the makedepends array
  • Added cmake to the makedepends array
  • Renamed version custom variable to _version

pjbroad commented on 2021-06-27 01:36 (UTC)

@NetSysFire Perhaps just modify the PKGBUILD to add "EXE=el.linux.bin" to the make command line and change the name of the installed executable to el.linux.bin.

NetSysFire commented on 2021-06-27 00:58 (UTC)

A bug was just fixed which caused the script to not work. https://github.com/raduprv/Eternal-Lands/commit/fddcfc92a0d9f15602025280005c47761b5b688c The PKGBUILD needs to be updated to reflect that change. It also seems the provided Makefile is legacy and cmake should be used instead.

encelo commented on 2021-04-14 08:48 (UTC) (edited on 2021-07-27 21:31 (UTC) by encelo)

Updated to client and data 1.9.5.9-1

  • Using GitHub release archive for sources
  • Added sdl2_ttf to the depends array
  • Removed git from the makedepends array
  • Updated the list of installed data files

encelo commented on 2020-09-19 14:04 (UTC)

I have migrated the explicit git clone to a VCS source line and removed gzip from the makedepends array.