Package Details: ffmpeg-libfdk_aac 1:4.2.2-4

Git Clone URL: https://aur.archlinux.org/ffmpeg-libfdk_aac.git (read-only, click to copy)
Package Base: ffmpeg-libfdk_aac
Description: Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)
Upstream URL: https://ffmpeg.org/
Licenses: GPL3, custom:libfdk-aac
Conflicts: ffmpeg
Provides: ffmpeg=4.2.2, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: korrode
Maintainer: bwidawsk
Last Packager: bwidawsk
Votes: 49
Popularity: 0.69
First Submitted: 2013-07-12 10:24
Last Updated: 2020-04-19 19:14

Dependencies (58)

Required by (1000)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

misanthropist commented on 2020-03-27 07:14

@ed_o
I also realized, that if any packages you have installed depend on ffmpeg, the official ffmpeg package will be installed by pacman -Syu after you remove ffmpeg-libfdk_aac. This isn't a problem per se, but after rebuilding ffmpeg-libfdk_aac, you get a question if you want to replace ffmpeg. Just answer yes. And you may need to run pacman -Syu again, after reinstalling ffmpeg-libfdk_aac, to sort out dependencies. You probably won't, but doing it anyway won't do any harm; if nothing needs to be done, pacman will return with a message to that effect.

ed_o commented on 2020-03-27 07:09

@misanthropist Thank you a lot for your advice, and information about arch-chroot environment - I am still a novice, and can benefit greatly from what veterans pass on to me. For future reference, these are the steps that I took to fix my conflict issue, thanks to @misanthropist

pacman -Rdd dav1d

pacman -Syu

And after the upgrade was finished

pacman -S dav1d

yay ffmpeg-libfdk_aac

And re-installed with Clean Build All option

misanthropist commented on 2020-03-27 06:57

@ed_o
If you can't update with pacman -Syu, try force removing ffmpeg-libfdk_aac as well, using pacman -Rdd ffmpeg-libfdk_aac. Then BEFORE rebuilding ffmpeg-libfdk_aac, run pacman -Syu again. And finally rebuild and reinstall ffmpeg-libfdk_aac.

I do AUR builds in a clean chroot environment, that I've set up solely for that purpose. That way if anything breaks, I still have a working system. And it has saved me a lot of headaches. Perhaps something worth looking in to?
https://wiki.archlinux.org/index.php/Chroot#Using_arch-chroot.
Also, the recommended path is to not use AUR helpers, such as yaourt, but to use makepkg directly. Using AUR packages can sometimes be a PITA, and breakages like the one you got aren't unheard of. I do hope you made a backup.

ed_o commented on 2020-03-27 06:32

@misanthropist Thank you for your advice. Unfortunately, removing dav1d as suggested seem to have broken all media players on my system. Also, I found that

:: installing dav1d (0.6.0-1) breaks dependency 'libdav1d.so=3-64' required by ffmpeg-libfdk_aac

aforementioned was linked to an update of VLC. As of now, reinstalling dav1d does not fix the breakage. Could you advise me on how to fix the system? Thank you in advance

misanthropist commented on 2020-03-27 06:13

@ed_o
You need to rebuild ffmpeg-libfdk_aac when its dependencies get updated. In case of conflicts, you may need to force remove the dependencies before updating.

Try

pacman -Rdd dav1d

then

pacman -Syu

and finally rebuild and reinstall ffmpeg-libfdk_aac

N.B. The above should work, and this what I normally do when a dependency update makes a rebuild necessary. However, I haven't done this update yet, and I may have overlooked something, so to be sure, keep a backup in case something goes wrong.

ed_o commented on 2020-03-27 05:47

Performing today's Arch update, I this conflict pops up

looking for conflicting packages...

error: failed to prepare transaction (could not satisfy dependencies)

:: installing dav1d (0.6.0-1) breaks dependency 'libdav1d.so=3-64' required by ffmpeg-libfdk_aac

Error installing repo packages

Could you be so kind to have a look into it? Thank you!!

bitsfritz commented on 2020-02-08 15:54

tag needs update:

cbb3c9497549f8856d8cd37ac63af1406a784e58 => 4.2.1

b53940e13dde81d721621b4d5296eede5795aadd => 4.2.2

:-))

marcin commented on 2020-01-15 23:44

Can't perform arch upgrade:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing x264 (3:0.159.r2991.1771b55-1) breaks dependency 'libx264.so=157-64' required by ffmpeg-libfdk_aac

Also can't remove ffmpeg-libfdk_aac as too many stuff depends on it :-(

Workaround: I added x264 to ignore list in /etc/pacman.conf to perform the system upgrade: IgnorePkg = x264.

shillshocked commented on 2020-01-03 02:20

If you want https to work with this version of ffmpeg and still get it to build, you should remove the --enable-gnutls \ line in the pkgbuild and instead add --enable-openssl \

This is because of the --enable-nonfree line creating a conflict.

bwidawsk commented on 2019-11-06 21:13

@Zeioth: Yes, you must temporarily remove ffmpeg update x265 and then rebuild ffmpeg.