Package Details: flexget 3.1.56-1

Git Clone URL: (read-only, click to copy)
Package Base: flexget
Description: Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
Upstream URL:
Licenses: MIT
Submitter: jonkristian
Maintainer: redfish
Last Packager: redfish
Votes: 69
Popularity: 0.037645
First Submitted: 2009-09-11 19:38
Last Updated: 2020-05-24 01:19

Latest Comments

1 2 3 4 5 6 ... Next › Last »

youngian commented on 2021-04-09 15:53

In addition to python-brotli, I also had to install python-babelfish to get this to run.

I am also getting this error repeatedly that looks like it's coming from one of the plugins, even though I'm not using the plugin: ImportError: cannot import name 'cached_property' from 'werkzeug' (/usr/lib/python3.9/site-packages/werkzeug/

cheezsteak commented on 2021-01-03 22:56

I had to add install python-brotli 1.0.9-4 to successfully run flexget --version. I don't know what version it should be or if its required by this package or one of it's dependencies.

tuxitop commented on 2019-09-08 14:14

What is the point of including the flexget@.service file, if you are not installing it in the PKGBUILD?

redfish commented on 2018-11-18 18:21

@je-vv: thanks, merged. I kept the min version specs for now, though, they don't hurt.

je-vv commented on 2018-11-04 05:12

This patch might be of interest:

diff -Naur flexget.orig/PKGBUILD flexget/PKGBUILD
--- flexget.orig/PKGBUILD       2018-11-03 22:59:17.800654614 -0600
+++ flexget/PKGBUILD    2018-11-03 23:04:58.118357988 -0600
@@ -17,35 +17,35 @@

          # documented in
-         'python-feedparser>=5.2.1'
-         'python-sqlalchemy>=1.0.9'
+         'python-feedparser'
+         'python-sqlalchemy'
-         'python-beautifulsoup4>=4.5'
-         'python-html5lib>=0.11'
+         'python-beautifulsoup4'
+         'python-html5lib'
-         'python-requests>=2.16.3'
-         'python-dateutil>=2.5.3'
-         'python-jsonschema>=2.0'
-         'python-path>=8.1.1'
-         'python-pathlib>=1.0'
-         #'python-guessit' # feature disabled until upstream updates to latest API
+         'python-requests'
+         'python-dateutil'
+         'python-jsonschema'
+         ''
+         # 'python-pathlib'
+         'python-guessit'
-         'python-apscheduler>=3.2.0'
-         'python-terminaltables>=3.1.0'
-         'python-colorclass>=2.2.0'
-         'python-cherrypy>=3.7.0'
-         'python-flask>=0.7'
-         'python-flask-restful>=0.3.3'
+         'python-apscheduler'
+         'python-terminaltables'
+         'python-colorclass'
+         'python-cherrypy'
+         'python-flask'
+         'python-flask-restful'
-         'python-flask-compress>=1.2.1'
-         'python-flask-login>=0.4.0'
-         'python-flask-cors>=2.1.2'
-         'python-pyparsing>=2.0.3'
+         'python-flask-compress'
+         'python-flask-login'
+         'python-flask-cors'
+         'python-pyparsing'
-         'python-future>=0.15.2'
+         'python-future'
 optdepends=('python-guppy: for memusage plugin' #AUR#
             'python-transmissionrpc: Transmission support' #AUR#
@@ -66,7 +66,7 @@
 prepare() {
   cd "${_pkgname}"-"${pkgver}"

-  #msg "Patching shebangs to point to python2"
+  #msg "Patching shebangs to point to python"
   sed -i '1s/python2/python/' flexget{,/ui}/

   # Don't use the requirements.txt with pinned deps
@@ -82,6 +82,9 @@
   # zxcvbn-python has been renamed zxcvbn
   sed -i 's/zxcvbn-python/zxcvbn/' requirements.txt

+  # pathlib no longer required since python 3.4
+  sed -i 's/pathlib.*//' requirements.txt
   # disable this parser because python-guessit API changed and upstream
   # needs to be patched to support it.
   rm flexget/plugins/parsers/

je-vv commented on 2018-10-21 06:42

Please, change dependency from python-path, to, which is the same but available from official repos. Please also remove dependency upon python-pathlib, that's not required at all on python 3. Some tweaks to requirements.txt might be required

highway commented on 2018-08-26 22:53

After another round of issues due to updates and broken functionality, I uninstalled flexget and all of its depends using pacman. I kept setuptools installed, and installed python2-virutalenv and python2-pip. I followed the instructions on the flexget page for setting up a virtualenv for ONLY flexget using python2 (python3 seems to have issues at this time). This seems to be working well and running OK. This process creates a build of flexget and its depends (independent of Arch) in a local folder somewhere, so it can be executed but will never interfere with Arch packages. I don't ever plan on updating the virtualenv or the packages/depends installed inside of that folder. Hopefully I can now use flexget in peace, without it breaking in an attempt to give me feature updates I don't need and won't use.

highway commented on 2018-04-29 13:21

@cgirard - thank you, that fixed it!

file path if anyone else needs it:


cgirard commented on 2018-04-23 13:40

@highway: it is because zxcvbn-python is now zxcvbn. The python require file should be updated.

highway commented on 2018-04-21 23:54

I seem to have an issue with the latest update of python2-zxcvbn breaking functionality. The error I receive is: "pkg_resources.DistributionNotFound: The 'zxcvbn-python' distribution was not found and is required by FlexGet"

Is anyone else experiencing this?