Package Details: franz 1:5.6.1-8

Git Clone URL: https://aur.archlinux.org/franz.git (read-only, click to copy)
Package Base: franz
Description: Free messaging app for services like WhatsApp, Slack, Messenger and many more.
Upstream URL: https://meetfranz.com
Licenses: Apache
Submitter: 314eter
Maintainer: ItachiSan
Last Packager: ItachiSan
Votes: 146
Popularity: 0.79
First Submitted: 2017-10-26 11:34
Last Updated: 2021-02-23 21:29

Pinned Comments

ItachiSan commented on 2019-10-07 08:26

If you have troubles, read this message!

Please go to the relevant section of this comment in order to make both your and my life easier :)

  1. I get an error when upgrading packages
  2. Errors when starting the app like: the chat area is all blue

Now, to the resolutions!

1. I cannot upgrade Electron

This is intended; since the PKGBUILD for Franz 5.5.0-4, the package marks as dependency a version-locked Electron package in order to avoid issues with binary modules over upgrades.

In such scenario, you should:

  1. Mark this package as out of date
  2. Do you regular updates with: pacman -Syu --ignore electron

If you want however to upgrade the Electron package, do

  1. Upgrade the electron package with pacman -S --assume-installed electron=FRANZ.REQUIRED.VERSION electron
  2. Rebuild Franz if needed
2. The app opens but I got a blue screen and nothing more

The package depends on Node.js native stuff which are compiled at build time, which makes it break on Electron updates.

With a PKGBUILD newer than 2020-11-15, you should always have a correct matching between Electron and Franz versions.

If you would like to help me on this, whenever you have problems starting it, do the following:

  1. Open Franz
  2. Franz is broken: maybe for a recent update?
  3. Reinstall Franz from AUR; this will make it rebuild the native blobs
  4. Re-open Franz
  5. Franz should work fine; if so, it was a Node.js/Electron/else update problem

If the above steps help you, report the package as outdated here and write in the comment something like:

Electron update broke Franz

If you have some other issues, you should open the developer tools and give me its output, in addition to what is your environment, so I can figure out if it is a packaging issue (my job to fix) or an upstream/code issue (their job to fix); in the second case, I will open a bug request and mention it in a comment, so that you can track it.

Hope this was a good explanation, might get updates if I missed something :)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ilpanich commented on 2021-03-06 15:25

Hi. Can't build on my system...

--> Using Electron package: electron

--> Electron package version: 11.3.0

lerna notice cli v4.0.0

lerna info versioning independent

lerna info bootstrap root only

npm ERR! code ERESOLVE

npm ERR! ERESOLVE unable to resolve dependency tree

npm ERR!

npm ERR! Found: react@16.6.3

npm ERR! node_modules/react

npm ERR! react@"16.6.3" from the root project

npm ERR!

npm ERR! Could not resolve dependency:

npm ERR! peer react@"^16.7.0" from forms@1.2.1

npm ERR! packages/forms

npm ERR!

npm ERR! Fix the upstream dependency conflict, or retry

npm ERR! this command with --force, or --legacy-peer-deps

npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

npm ERR!

npm ERR! See /home/emanuele/.cache/yay/franz/src/npm_cache/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:

lerna ERR! npm install exited 1 in 'franz'

lerna ERR! npm install exited 1 in 'franz'

mattematt commented on 2021-01-13 17:31

When running pacman update tonight I am getting the following error:

:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (11.2.0-1) breaks dependency 'electron=11.1.1' required by franz

Edit: Fixed on 2021-01-14 by reinstalling the latest version of franz

billypilgrim commented on 2020-11-06 12:16

I'm getting this warning: gyp ERR! configure error gyp ERR! stack Error: Command failed: /usr/bin/python -c import sys; print "%s.%s.%s" % sys.version_info[:3]; gyp ERR! stack File "<string>", line 1 gyp ERR! stack import sys; print "%s.%s.%s" % sys.version_info[:3]; gyp ERR! stack ^ gyp ERR! stack SyntaxError: invalid syntax gyp ERR! stack gyp ERR! stack at ChildProcess.exithandler (node:child_process:309:12) gyp ERR! stack at ChildProcess.emit (node:events:327:20) gyp ERR! stack at maybeClose (node:internal/child_process:1055:16) gyp ERR! stack at Process.ChildProcess._handle.onexit (node:internal/child_process:288:5)

I guess we need to patch to use python3 somewhere?

ItachiSan commented on 2020-10-30 21:01

@dnl_tp master has lots of stuff that are not included in the real release. However, due to how new is our Electron, we might want to use the latest beta... Lemme think about that :)

dnl_tp commented on 2020-10-14 04:08

Franz has stopped working for me so I changed the PKGBUILD to use the master branch and removed the now outdated electron-9.patch, then it worked well again!

dnl_tp commented on 2020-07-09 05:33

There is an electron 9 branch with some more patches:
https://github.com/meetfranz/franz/tree/chore/electron-9.x

melkopisi commented on 2020-07-06 09:54

I installed a fresh Manjaro Gnome then installed Franz the current version 1:5.5.0-3 and I have a small issue as I go to settings, enable the dark mode and disable displaying disabled services tabs but when I refresh or quiet the app then open it again these settings reset themselves I have to re-enable them again every time I start the app for the first time or refresh.

ItachiSan commented on 2020-06-24 12:55

It seems to me that re-building the package works, so I will just bump the release number. Please let me know if there are other issues.

artofakume commented on 2020-06-17 21:38

I can confirm the patch solved the issue. Thank you!

ItachiSan commented on 2020-06-17 21:01

The package is now including @yuyichao patch. Lemme know if it works for you!

I am currently moving to a new laptop thus I only tested the package a bit in a VM and it worked.