Package Details: google-drive-ocamlfuse 0.7.30-3

Git Clone URL: https://aur.archlinux.org/google-drive-ocamlfuse.git (read-only, click to copy)
Package Base: google-drive-ocamlfuse
Description: FUSE-based file system backed by Google Drive, written in OCaml
Upstream URL: https://astrada.github.io/google-drive-ocamlfuse/
Keywords: drive fuse google ocaml
Licenses: MIT
Submitter: mlq
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 62
Popularity: 0.008897
First Submitted: 2013-10-14 21:44 (UTC)
Last Updated: 2022-10-16 07:07 (UTC)

Pinned Comments

pricechrispy commented on 2017-04-25 17:39 (UTC) (edited on 2022-10-16 06:40 (UTC) by pricechrispy)

Before you flag this package out-of-date:

According to the official project page: https://astrada.github.io/google-drive-ocamlfuse/

Find latest release versions here: https://launchpad.net/~alessandro-strada/+archive/ubuntu/ppa

The latest releases are not all tagged versions on GitHub.

For the latest development versions on git, try: https://aur.archlinux.org/packages/google-drive-ocamlfuse-git

OLD official project page: http://gdfuse.forge.ocamlcore.org/

OLD release versions here: https://forge.ocamlcore.org/frs/?group_id=305

Latest Comments

1 2 3 4 5 6 .. 20 Next › Last »

alexdsan commented on 2023-12-06 01:35 (UTC)

I can't isntall.

ocamlfuse - exit status 8 tiny_httpd - exit status 8 camlidl - exit status 4 gapi-ocaml - exit status 8 google-drive-ocamlfuse - exit status 8 ocaml-cryptokit - exit status 4 ocamlnet - exit status 8

tomas commented on 2023-11-05 12:05 (UTC)

not working, dependencies issue

ferrvittorio commented on 2023-08-09 14:47 (UTC)

Cannot install:

-> Installazione dei seguenti pacchetti non riuscita. È richiesto l'intervento manuale: ocaml-ppx_here - exit status 8 ocaml-lwt - exit status 8 ocamlnet - exit status 8 gapi-ocaml - exit status 8 ocaml-ppx_let - exit status 8 ocaml-ounit - exit status 8 ocamlfuse - exit status 8 tiny_httpd - exit status 8 ocaml-domainslib - exit status 8 google-drive-ocamlfuse - exit status 8 ocaml-cryptokit - exit status 4 camlidl - exit status 4 ocaml-curl - exit status 8

arash-m commented on 2023-08-07 23:57 (UTC)

It can't be installed. Fails with a dependency issue.

error: could not find all required packages:
    ocaml-base>=0.16.0 (wanted by: google-drive-ocamlfuse-git -> ocaml-ounit -> ocaml-lwt -> ocaml-ppx_let)

pmatos commented on 2023-08-01 18:53 (UTC)

yay -Sy google-drive-ocamlfuse :: Synchronising package databases... core is up to date extra is up to date community is up to date multilib is up to date -> No AUR package found for ocaml-base>=0.16.0 -> No AUR package found for ocaml-base>=0.16.0 -> could not find all required packages: ocaml-base >=0.16.0

What's going on?

emild commented on 2023-07-01 22:57 (UTC) (edited on 2023-07-01 23:10 (UTC) by emild)

For some uploads (not large ones) I see in the log:

[226.130625] TID=0: BEGIN: Uploading file (id=154, path=/.shared/......................
[240.214013] TID=1: Flushing DB...done
[406.853707] TID=0: Error during request: Code: 65, Description: CURLE_SEND_FAIL_REWIND, ErrorBuffer: necessary data rewind wasn't possible
[406.853720] TID=0: Giving up

Then the file looks like it's uploaded in a file manager, but when looking in Google Drive, it's got 0 bytes. A massive pain because now I wonder if each file was uploaded or not.

This is with 0.7.30.

Edit: raised bug upstream - https://github.com/astrada/google-drive-ocamlfuse/issues/820

pricechrispy commented on 2023-03-02 06:00 (UTC)

@krvkir This package builds. The error you receive is from a dependency "camlidl". Currently this dependency has issues building: https://aur.archlinux.org/packages/camlidl

@vmartins The error you receive is from a dependency "ocaml-cryptokit". Please apply the patch mentioned in this comment https://aur.archlinux.org/packages/ocaml-cryptokit#comment-885368

vmartins commented on 2023-03-01 17:50 (UTC) (edited on 2023-03-01 17:50 (UTC) by vmartins)

==> Starting package()...
dune: option '--libdir': the path must be absolute to avoid ambiguity
Usage: dune install [OPTION]… [PACKAGE]…
Try 'dune install --help' or 'dune --help' for more information.
==> ERROR: A failure occurred in package().

krvkir commented on 2022-12-06 11:22 (UTC) (edited on 2022-12-06 11:23 (UTC) by krvkir)

Couldn't build it today:

ranlib: ./libcamlidl.a: error reading comerror.o: file truncated
make[1]: *** [Makefile.unix:20: libcamlidl.a] Error 2
make[1]: Leaving directory '/home/krvkir/.cache/yay/camlidl/src/camlidl-camlidl109/runtime'
make: *** [Makefile:19: all] Error 2

Neither this package nor the -git one builds.

sunplan commented on 2022-05-11 06:28 (UTC)

It seems that /usr/doc should be /usr/share/doc.