Package Details: geeqie-git 20210627-1

Git Clone URL: https://aur.archlinux.org/geeqie-git.git (read-only, click to copy)
Package Base: geeqie-git
Description: Lightweight image viewer
Upstream URL: http://www.geeqie.org/
Licenses: GPL2
Conflicts: geeqie
Provides: geeqie
Submitter: Zuf
Maintainer: ipha
Last Packager: ipha
Votes: 44
Popularity: 0.30
First Submitted: 2012-01-06 16:19
Last Updated: 2021-07-17 00:17

Latest Comments

1 2 3 4 Next › Last »

JDAturbo commented on 2021-07-16 13:31

The source URL should be changed to git+git://git.geeqie.org/geeqie.git.

deadite66 commented on 2021-05-15 11:55

depends: libdjvu needs changing to djvulibre

Ray commented on 2021-01-30 01:25

Geeqie will no longer install in YAY or in pamac. Please update the AUR build. Geeqie is an invaluable tool

rouelle commented on 2020-12-11 04:52

I removed lines 34 and 35 of the PKGBUILD before building the package: 34 --disable-lua \ 35 --disable-pdf

The last commit, on 2020-12-10, makes geeqie perfectly usable in Wayland but you have to check "Use GPU acceleration via Clutter library" in Settings → Image.

The pdf preview is a bitmap of the first page (if multi-page document), better than only having a pdf icon.

shapeshifter commented on 2020-06-18 06:24

Has anyone managed to get this to work under Wayland (sway)? For me, it launches but no image is displayed, just a black or gray background. I can interact with it but the images aren't rendered.

ipha commented on 2020-04-09 20:13

The github mirror used to be up to date...

I'll switch it back to the self hosted repo, but it's really unstable. It frequently goes down and when it is up it's incredibly slow, I'm currently cloning at a blazing 15KB/s.

jkl commented on 2020-04-09 18:36

It seems that the geeqie git is not on github, but here: http://geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git

graysky commented on 2020-01-02 15:36

@stevenhoneyman - Can you please update/modernize the PKGBUILD? Example: https://gist.github.com/graysky2/1a716839f6cb52223c9f3fe2d3113e8a

haawda commented on 2019-07-21 13:22

For me only disabling lua works ('--disable-lua').

menta commented on 2019-06-18 13:49

It seems that the correct Lua dependency is 'lua51' instead of 'lua'.

If the build fails with a Lua related error one of the following modifications of the PKGBUILD file may solves the problem:

  • Add the '--disable-lua' option to autogen.sh.

  • Add 'export LUA_CFLAGS=-I/usr/include/lua5.1' and 'export LUA_LIBS=-llua5.1' before calling autogen.sh.