Package Details: evince-git 42.0+9+g53f38dae-1

Git Clone URL: https://aur.archlinux.org/evince-git.git (read-only, click to copy)
Package Base: evince-git
Description: Simply a document viewer
Upstream URL: http://projects.gnome.org/evince/
Licenses: GPL
Conflicts: evince
Provides: evince
Submitter: maurofruet
Maintainer: swiftscythe
Last Packager: swiftscythe
Votes: 3
Popularity: 0.000000
First Submitted: 2012-10-28 19:53 (UTC)
Last Updated: 2022-03-23 15:13 (UTC)

Required by (29)

Sources (1)

Latest Comments

Dylan14 commented on 2022-04-07 16:07 (UTC)

@swiftscythe - yeah that should be implemented upstream, but I'm not sure how gnome handles merge requests compared to a project on github.

swiftscythe commented on 2022-04-07 05:12 (UTC)

@Dylan14, shouldn't that be fixed upstream?

Dylan14 commented on 2022-04-06 20:46 (UTC)

The man page that evince generates directs to a page which redirects to the main Gnome App wiki page. Here is a patch that fixes this: https://github.com/Dylan1496/aur-pkgbuilds/blob/master/manpage.patch

frabjous commented on 2022-03-22 22:35 (UTC)

From what I can tell, this won't build without "gi-docgen" installed. Should be a dependency.

debb commented on 2021-07-27 21:22 (UTC)

Dependencies needed: - gspell - gnome-desktop - libhandy

rharish commented on 2021-03-24 15:37 (UTC)

Missing make dependency meson.

taifunbrowser commented on 2018-08-14 19:33 (UTC)

Dependency needed: gspell (1.6+)

swiftscythe commented on 2015-10-04 13:08 (UTC)

@craeckie: since the PKGBUILD has a pkgver() function, the version is updated automagically when you build it, so there's no need to update the PKDGBUILD for every git commit.

craeckie commented on 2015-10-04 12:33 (UTC)

current version: 3.18.0.r30.g696d1b5-1

Akseli0x61 commented on 2014-08-07 17:45 (UTC)

Dependencies needed: gnome-common gtk-doc yelp-tools adwaita-icon-theme-git

foobarrior commented on 2014-08-07 05:44 (UTC)

Please add adwaita-icon-theme-git to dependencies

efernandes commented on 2014-02-03 21:57 (UTC)

PKGBUILD updated :)

wil93 commented on 2014-02-02 23:32 (UTC)

It seems that the bug with automake 1.13 ([1]) has been solved (I just successfully built the package using automake 1.14). I think that the "<1.13" string can be now removed from the dependencies. [1] https://bugs.archlinux.org/task/33285

rafaelff commented on 2013-03-02 16:37 (UTC)

@maurofruet: That's expected. Running "pacman -Q gtk3" will show you that you have gtk+ version 3.6.4, which is what Archlinux provides at the moment. GNOME is somewhat close to release a new version (probably March 25 [1] ) and this requirement will be fulfilled. [1] https://live.gnome.org/ThreePointSeven

maurofruet commented on 2013-03-02 14:58 (UTC)

It doesn't work for me. I get the following error: checking for LIBDOCUMENT... no configure: error: Package requirements (gtk+-3.0 >= 3.7.5 gio-2.0 >= 2.33.2 gmodule-no-export-2.0 >= 2.33.2 gmodule-2.0) were not met: Requested 'gtk+-3.0 >= 3.7.5' but version of GTK+ is 3.6.4 Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables LIBDOCUMENT_CFLAGS and LIBDOCUMENT_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

rafaelff commented on 2013-03-01 21:03 (UTC)

yep, gnome-common currently doesn't support automake 1.13. For more information, see https://bugs.archlinux.org/task/33285 I think the easier solution, for now, is to add automake-1-12 as makedependency. It works just fine.

maurofruet commented on 2013-03-01 20:53 (UTC)

You're right, gtk-doc is missing as make dependency, as well as gnome-common. I don't get why the leading slash should be removed: I've read many PKGBUILDs of Gnome packages in the extra repository, but none of them is without the leading slash. I think that the error is in the wiki (no updates for a lot of months). However, even after adding the new make dependencies, I can't compile the package. What about you? I get an error with automake because of a bug of automake 1.13, which can be temporarily fixed by adding: AUTOMAKE=automake before running ./autogen To compile, evince still requires newer versions of some packages, including gtk3 >= 3.7.5, but the version currently present in testing is 3.6.4 and gtk3-git has been flagged out-of-date.

rafaelff commented on 2013-03-01 11:10 (UTC)

missing makedependency: gtk-doc error in install file: remove leading '/' from parameters, as it should be 'usr/share/glib-2.0/schemas' and 'usr/share/glib-2.0/schemas' (https://wiki.archlinux.org/index.php/GNOME_Package_Guidelines)

maurofruet commented on 2012-11-05 08:07 (UTC)

You are right, I've modified the PKGBUILD. I didn't notice it because yelp-tools was already installed on my system.

TheStochasticMan commented on 2012-11-05 00:31 (UTC)

It seems like yelp-tools is also a make dependency... PKGBUILD should be updated accordingly