Package Details: ghostwriter-git v1.8.0.r0.g78d7f3a-1

Git Clone URL: https://aur.archlinux.org/ghostwriter-git.git (read-only, click to copy)
Package Base: ghostwriter-git
Description: ghostwriter is a cross-platform, aesthetic, distraction-free Markdown editor.
Upstream URL: https://github.com/wereturtle/ghostwriter
Licenses: GPL3
Conflicts: ghostwriter
Provides: ghostwriter
Submitter: TamCore
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 8
Popularity: 0.010317
First Submitted: 2016-03-28 19:04
Last Updated: 2019-06-21 20:55

Latest Comments

amadeusp81 commented on 2021-05-20 11:28

Would be awesome if this package could be updated.

maxemilian commented on 2021-05-12 13:47

Could you update? the 2.0 version?

Almagest commented on 2019-06-21 17:53

Hello, it appears you have a missing dependency on qt5-webengine. I received this error when trying to install your PKG:

Info: creating stash file /home/almagest/.cache/yay/ghostwriter-git/src/ghostwriter/.qmake.stash Project ERROR: Unknown module(s) in QT: webenginewidgets webengine

Which was fixed upon the installation of: https://www.archlinux.org/packages/extra/x86_64/qt5-webengine/

neitsab commented on 2017-06-06 21:46

Thank you! ghostwriter's stable package maintainer J5lx has found out that hunspell is actually a runtime dependency, instead of just a build-time or optional dep, so in a next update maybe you could move it to the depends array too!
Cheers

ivanruvalcaba commented on 2017-06-05 02:00

@neitsab Thanks a lot! Fixed.

Best regards.

neitsab commented on 2017-06-02 21:31

Hi, thanks for showing the way to get the interface use available translations! I have taken after your PKGBUILD to offer an update to the standard ghostwriter package in AUR, so as to get this basic feature there too.
In doing so, I realized that hunspell is required during the build, and that `lrelease` is provided by qt5-tools which is not included in the makedepends, resulting in a build error.

So the makedepends array should look like this:
makedepends=('git' 'qt5-tools' 'hunspell')

I have posted an updated PKGBUILD to the stable package comments if you want to take a look at the other changes I suggest. Cheers!

ivanruvalcaba commented on 2017-04-08 23:55

Please consider modifying the PKGBUILD to provide additional support for other languages than English. Here is a proposal: https://pastebin.com/e624PAD0

Best regards.

ninian commented on 2016-10-05 18:45

qtchooser should now be removed from makedepends array, as it seems to be provided by other qt5 packages?