Package Details: gns3-gui 2.2.25-1

Git Clone URL: https://aur.archlinux.org/gns3-gui.git (read-only, click to copy)
Package Base: gns3-gui
Description: GNS3 network simulator. Graphical user interface package.
Upstream URL: https://github.com/GNS3/gns3-gui
Licenses: GPL3
Groups: gns3
Submitter: korjjj
Maintainer: buzo
Last Packager: buzo
Votes: 80
Popularity: 0.35
First Submitted: 2014-05-13 18:56
Last Updated: 2021-09-14 15:57

Dependencies (13)

Required by (1)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

buzo commented on 2021-05-10 17:07

Thanks zbe and kazaii, fixed.

kazaii commented on 2021-05-09 15:49

zbe is correct. This has been broken for me since ~ Friday. Fixed it by deleting the contents of ~/.cache/yay/gns3-gui & gns3-server

then re-installing with: yay -S --editmenu gns3-server yay -S --editmenu gns3-gui

(say yes to editing the pkgbuild)

and adding (don't use quotes) "-e 's|^sentry-sdk==1.0.0$|sentry-sdk>=1.0.0|' \"

to similar entries in "prepare() {" section, (the sed commands)

example:

prepare() {
    cd "$pkgname-$pkgver"
    # Arch usually has the latest versions. Patch requirements to allow them.
    sed -i \
        -e 's|^psutil==5\.8\.0$|psutil>=5.8.0|' \
        -e 's|^distro==1\.5\.0$|distro>=1.5.0|' \
        -e 's|^sentry-sdk==1.0.0$|sentry-sdk>=1.0.0|' \   <---- here! 
        requirements.txt

Afte rebuilding both packages, I'm back in my lab. Thanks zbe!

zbe commented on 2021-05-07 07:08

gns3-gui doesn't start after updating to python-sentry_sdk 1.1.0-1.

Edit: Add "-e 's|^sentry-sdk==1\.0\.0$|sentry-sdk>=1.0.0|' \" to PKGBUILD.

buzo commented on 2021-04-09 19:33

cookiewookie: Should be fixed with 2.2.20, since upstream switched to sentry-sdk 1.0.0.

cookiewookie commented on 2021-04-05 14:35

python-sentry_sdk fails to download from pypi!

csirek commented on 2020-10-29 07:27

After i upgraded from 2.2.5 to 2.2.15 the gns3 does'nt start with a lot of error like this:

$ gns3 Traceback (most recent call last): File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 567, in _build_master ws.require(requires) File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 884, in require needed = self.resolve(parse_requirements(requirements))

etc etc etc....

And the last line is:

pkg_resources.DistributionNotFound: The 'jsonschema==3.2.0' distribution was not found and is required by gns3-gui

So the main problem is need to install "python-jsonschema" 3.2.0-2 and after that the gns3 run as normal. So this jsonschema is a dependency but not install when i upgrade (or remove the old and isntall the new) gns3.

buzo commented on 2020-08-16 09:55

The problems regarding requirements should be fixed with the update to 2.2.12.

Anonymous comment on 2020-08-09 18:19

@demolisher thanks for your answer! but after downgrading python3-PyQt5 to 5.14.1 it doesnt help me, gns3-gui still cant load at all. I still have the same output log of gns3-gui before

betrunkenaffe commented on 2020-08-06 01:41

I resolved by using python-pip and then downloading the specific version of psutil from https://pypi.org/project/psutil/5.7.0/

theinterwebthing commented on 2020-08-03 00:06

Unable to start

File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 785, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'psutil==5.7.0' distribution was not found and is required by gns3-gui

Updating psutil==5.7.0 to psutil==5.7.1 in /usr/lib/python3.8/site-packages/gns3_gui-2.2.11-py3.8.egg-info/requires.txt solves the issue.

Note these are hardcoded upstream in the requirements.txt