Package Details: gnuradio-git v3.11.0.0git.717.g72e21b54c-1

Git Clone URL: (read-only, click to copy)
Package Base: gnuradio-git
Description: General purpose DSP and SDR toolkit, with drivers for usrp and fcd.
Upstream URL:
Keywords: sdr
Licenses: GPL
Conflicts: gnuradio, gnuradio-companion
Provides: gnuradio, gnuradio-companion
Submitter: None
Maintainer: karel
Last Packager: karel
Votes: 25
Popularity: 0.000000
First Submitted: 2010-08-05 12:14 (UTC)
Last Updated: 2024-04-29 08:59 (UTC)

Required by (49)

Sources (1)

Latest Comments

1 2 3 4 5 6 .. 10 Next › Last »

ncicek commented on 2023-03-12 19:35 (UTC)

I had to install 2 additional dependencies in order to get this to compile: docbook-xsl and docbook-xml. Please add them as dependencies.

sausix commented on 2022-05-01 16:10 (UTC)

Snaps into Python 3.6 (AUR: python36) if installed (additionally). Devs have multiple versions installed.

-- PYTHON_EXECUTABLE not set - using default python3
-- Found PythonInterp: /usr/bin/python3.6 (found suitable version "3.6.15", minimum required is "3.6.5") 
-- Found PythonLibs: /usr/lib/ (found suitable exact version "3.6.15") 

It's not a symlink problem:

lrwxrwxrwx 1 root root     7 24. Mär 00:05 /usr/bin/python -> python3
lrwxrwxrwx 1 root root    10 24. Mär 00:05 /usr/bin/python3 -> python3.10

Tweaking with -DPYTHON_EXECUTABLE=/usr/bin/python3:

-- User set python executable /usr/bin/python3
-- Found PythonInterp: /usr/bin/python3 (found suitable version "3.10.4", minimum required is "3.6.5") 
-- Could NOT find PythonLibs: Found unsuitable version "3.6.15", but required is exact version "3.10" (found /usr/lib/

PythonLibs is still off the way.

ThomasZeGerman commented on 2022-04-03 14:57 (UTC)

Builds, but doesn't actually install gnuradio-companion

dreieck commented on 2021-12-19 18:42 (UTC)

Can you strip the trailing v from the version?

EndlessEden commented on 2021-11-08 23:17 (UTC)

please add gtk3 to depends. as its a requirement for GrComponent and gnuradio-companion now.

dreieck commented on 2021-09-30 17:52 (UTC)

Can you please add =${pkgver} to the provides-entries?

There are issues that some gr--packages need specific gnuradio-versions, like gr-rds-git which won't work with 3.8. It has that version requirement in it's dependency definitions set, but it can only be honoured if the gnuradio-packages also provide that.

Thanks for maintaining!

japm48 commented on 2020-04-17 08:02 (UTC)

Please, remove pygtk dependency. It is python2-only and no longer required (only python-gobject + gtk3 are needed).

MrHritik commented on 2020-02-24 21:40 (UTC)

==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
-> python-cheetah
-> swig
-> qwt

nickoe commented on 2019-07-11 23:16 (UTC)

It seems you need to add python-pyqt5 as depends as well otherwise we see "-- Dependency PYQT5_FOUND = FALSE"