Package Details: gnuradio-multi-rtl-git r43.cbc12d5-1

Git Clone URL: https://aur.archlinux.org/gnuradio-multi-rtl-git.git (read-only, click to copy)
Package Base: gnuradio-multi-rtl-git
Description: Multi-channel receiver with use of RTL-SDR dongles
Upstream URL: https://ptrkrysik.github.io/
Licenses: GPL3
Submitter: keenerd
Maintainer: keenerd
Last Packager: keenerd
Votes: 2
Popularity: 0.000000
First Submitted: 2016-06-24 02:45 (UTC)
Last Updated: 2016-06-24 02:46 (UTC)

Latest Comments

dreieck commented on 2021-09-30 15:52 (UTC)

Fails to build for me with

CMake Error at CMakeLists.txt:116 (message):
  GnuRadio Runtime required to compile gr-gsm

Installed is the currently latest gnuradio from the community repository, version 3.9.2.0-3.

Full build() output:

==> Starting build()...
-- The CXX compiler identification is GNU 11.1.0
-- The C compiler identification is GNU 11.1.0
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Build type not specified: defaulting to release.
-- Found Boost: /usr/lib64/cmake/Boost-1.76.0/BoostConfig.cmake (found suitable version "1.76.0", minimum required is "1.35") found components: filesystem system 
-- Found LOG4CPP: /usr/lib/liblog4cpp.so
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.8.0") 
-- Checking for module 'gmp'
--   Found gmp, version 6.2.1
-- Found GMP: /usr/lib/libgmpxx.so  
-- Using GMP.
-- Found MPLIB: /usr/lib/libgmpxx.so  
-- Found Boost: /usr/lib64/cmake/Boost-1.76.0/BoostConfig.cmake (found suitable version "1.76.0", minimum required is "1.76.0") found components: date_time program_options filesystem system regex thread unit_test_framework 
-- Found Volk: Volk::volk  
-- Checking for module 'cppunit'
--   Found cppunit, version 1.15.1
-- Found CPPUNIT: /usr/lib/libcppunit.so;dl  
-- Found Doxygen: /usr/bin/doxygen (found version "1.9.2") found components: doxygen dot 
CMake Error at CMakeLists.txt:116 (message):
  GnuRadio Runtime required to compile gr-gsm


-- Configuring incomplete, errors occurred!
See also "/[...]/gnuradio-multi-rtl-git/src/multi-rtl/build/CMakeFiles/CMakeOutput.log".
See also "/[...]/gnuradio-multi-rtl-git/src/multi-rtl/build/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().
    Aborting...

Thanks for maintaining!

dreieck commented on 2021-09-30 12:51 (UTC)

Please add provides=("gnuradio-multi-rtl"), conflicts=("gnuradio-multi-rtl").

Thanks for maintaining!