Package Details: gogs-git 2:0.11.19.0609+1+6197a7639-1

Git Clone URL: https://aur.archlinux.org/gogs-git.git (read-only)
Package Base: gogs-git
Description: Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language.
Upstream URL: http://gogs.io/
Keywords: git gitea github gitlab gogits
Licenses: MIT
Conflicts: gogs
Provides: gogs
Replaces: gogs-master-git
Submitter: fanningert
Maintainer: surefire
Last Packager: surefire
Votes: 6
Popularity: 0.054774
First Submitted: 2014-05-13 15:42
Last Updated: 2017-06-13 05:36

Latest Comments

zargbell commented on 2017-04-13 13:15

...
github.com/gogits/gogs/cmd
github.com/gogits/gogs
cp '/tmp/yaourt-tmp-admin/aur-gogs-git/src/bin/gogs' .
cp: cannot stat '/tmp/yaourt-tmp-admin/aur-gogs-git/src/bin/gogs': No such file or directory
make: *** [Makefile:37: build] Error 1
==> ERROR: A failure occurred in build().
Aborting...

=========================================================
please add to PKGBUILD file variable GOBIN:
build() {
export GOPATH="$srcdir"
export GOBIN="$GOPATH/bin"
...
}

grandchild commented on 2017-03-29 03:38

@surefire, please add 'aarch64' (a.k.a. arm 64bit) to the arch array, it's running fine on my odroid-c2. thanks!

Diego.Florez commented on 2017-03-11 16:37

Upgrading from 1.x to 2.x

# mkdir -p /var/lib/gogs/custom/conf
# cp /srv/gogs/conf/app.ini.pacsave /var/lib/gogs/custom/conf/app.ini
# systemctl restart gogs

infoised commented on 2017-03-08 16:47

@FoPref

By default, the root seems to be /var/lib/gogs/, so if you don't modify the service file, /var/lib/gogs/custom/conf/app.ini will be used.

FoPref commented on 2017-03-08 14:27

I updated from an older version and now my /srv/gogs/conf/app.ini seems to be ignored. How to migrate to the new version of this package?

surefire commented on 2017-03-08 11:40

@infoised, Thanks, it's true if not uses build-in ssh server.

infoised commented on 2017-03-08 10:34

In order to be able to use ssh clone, shell has to be set for the gogs user:

usermod -s /bin/sh gogs

surefire commented on 2017-02-22 15:29

@nyclocx check you config option STATIC_ROOT_PATH in "app.ini"

default precompiled path: /usr/share/gogs

nylocx commented on 2017-02-22 14:17

The package seems still broken at least the theme directories are off.
Using this two lines seems to work:

install -d "$pkgdir/usr/share/themes/gogs/default"
cp -rt "$pkgdir/usr/share/themes/gogs/default" ./{templates,public}

helmi77 commented on 2017-02-15 15:08

@letroll
According to commit 2fd69f1[1] the dependencies are now included in the repository, which means there is no need for Glide and subsequently no glide.yaml file.
As a solution just remove the lines starting with "glide" from the PKGBUILD.

[1] https://github.com/gogits/gogs/commit/2fd69f13d9599a6c58b47225565163fd7d87889f

All comments