Package Details: goneovim-bin 0.6.2-1

Git Clone URL: https://aur.archlinux.org/goneovim-bin.git (read-only, click to copy)
Package Base: goneovim-bin
Description: Neovim GUI written in Golang, using a Golang qt backend
Upstream URL: https://github.com/akiyosi/goneovim
Licenses: MIT
Conflicts: goneovim
Provides: goneovim
Submitter: Moonglade
Maintainer: alerque
Last Packager: alerque
Votes: 7
Popularity: 0.017234
First Submitted: 2020-06-14 05:30 (UTC)
Last Updated: 2022-06-21 16:57 (UTC)

Latest Comments

alerque commented on 2022-03-30 18:54 (UTC)

Nope @behonest using nightlies or VCS builds is not appropriate for a stable versioned package like this one.

behonest commented on 2022-03-28 08:57 (UTC)

@alerque Thanks. Perhaps we might use Nightly builds? https://github.com/akiyosi/goneovim/releases/tag/nightly. There is this https://aur.archlinux.org/packages/goneovim-git, but I wanted to avoid building it locally so that not to install GO, etc.

alerque commented on 2022-02-22 20:19 (UTC)

@behonest We update this package when upstream releases a new version. They have not done so yet in spite of the wording of that message. The master branch has been updated but they haven't made a new release yet.

behonest commented on 2022-02-19 13:19 (UTC)

Thanks for maintaining this package. When do we update it? I'm seen this bug: https://github.com/akiyosi/goneovim/issues/314#issuecomment-1024480290

behonest commented on 2022-01-22 12:43 (UTC)

@alerque Thanks! It works now

alerque commented on 2022-01-15 18:38 (UTC)

@behonest I've asked upstream about this. I've noticed before the way GitHub handles CDN stuff some artifacts get edge cached and replacing them can take a long time to hit everyone. It's possible upstream made the mistake of trying to hot-fix an issue without cutting a new release.

behonest commented on 2022-01-15 09:56 (UTC)

@alerque Thanks. Still it fails. What's sha256? I get

❯ sha256sum Goneovim-v0.5.1-linux.tar.bz2
4ac28a60c6241de3274cd89459dcd97c5f20e98322553b05ac32d6d31b7d09bd  Goneovim-v0.5.1-linux.tar.bz2

alerque commented on 2022-01-10 09:29 (UTC)

@behonest I just re-downloaded the file using the current version of the package and checked the checksum. It validates, so you should check your download.

behonest commented on 2022-01-10 09:23 (UTC)

I'm getting:

==> Validating source files with sha256sums...
    Goneovim-v0.5.1-linux.tar.bz2 ... FAILED
    goneovim.desktop ... Passed
    goneovim.ico ... Passed
==> ERROR: One or more files did not pass the validity check!

alerque commented on 2022-01-01 17:46 (UTC)

@seabassapologist Thanks for the heads up, the upstream binary appears to link to quite a few things now that it didn't the last time I checked. I've refreshed the dependency list, but be aware that the actual build here is coming from upstream and we're kind of at the mercy of their compile time options until we setup a proper source build.

seabassapologist commented on 2022-01-01 14:33 (UTC)

Please add qt5-declarative as a dependency, the app fails to start without libQt5Qml.so.5

$ goneovim                                                                                                                                                                                                                                                                    
goneovim: error while loading shared libraries: libQt5Qml.so.5: cannot open shared object file: No such file or directory

rnstlange commented on 2021-05-26 19:50 (UTC)

Please add "provides" field

azarmadr commented on 2021-05-08 09:52 (UTC) (edited on 2021-05-08 10:06 (UTC) by azarmadr)

unable to see the icon on taskmanager

PowerBall253 commented on 2021-04-11 20:40 (UTC)

I have updated the package to v0.4.11.

lahwaacz commented on 2020-05-30 13:03 (UTC)

This should be renamed to goneovim-bin because it does not build the source, but downloads a prebuilt binary. Or change the PKGBUILD to actually build from source.

sysroot commented on 2020-05-03 19:53 (UTC) (edited on 2020-05-03 19:57 (UTC) by sysroot)

I update the PKGBUILD, instructions for install:

1.- Visit and Download PKGBUILD, goneovim.desktop from:

https://gist.github.com/dbinary/2859651189a4cfea9eff2bb85424f22f

2.- Download

https://raw.githubusercontent.com/akiyosi/goneovim/master/cmd/goneovim/goneovim.ico

3.- Put all files in same dir and cd into

4.- run:

makepkg -si

markoff commented on 2020-04-16 12:41 (UTC)

Out of date. Can you please update?

Twiki commented on 2019-05-07 08:02 (UTC) (edited on 2019-05-07 08:02 (UTC) by Twiki)

After installation I miss quite a bit : setting.toml, gonvim.sh, gonvim.desktop, gonvim.ico, no plugins folder. Which results in no GUI. Except for gonvim.ico the other files and the plugin folder are in the downloaded Gonvim-0.3.4-linux.tar.gz archive (110MB). I also didn't notice any message(s) after installation that I had to do anything myself.