Package Details: guile-lib 0.2.7-2

Git Clone URL: https://aur.archlinux.org/guile-lib.git (read-only, click to copy)
Package Base: guile-lib
Description: Repository of useful code written in Guile Scheme
Upstream URL: http://www.nongnu.org/guile-lib/
Licenses: GPL3, LGPL3
Submitter: tantalum
Maintainer: bidulock (holos)
Last Packager: bidulock
Votes: 26
Popularity: 0.000000
First Submitted: 2008-09-17 22:05 (UTC)
Last Updated: 2021-05-24 23:00 (UTC)

Latest Comments

1 2 Next › Last »

missingSleepDeps commented on 2022-10-13 02:41 (UTC)

Builds for Manjaro when I say GUILE=/usr/bin/guile3 instead of /usr/bin/guile though

missingSleepDeps commented on 2022-10-13 02:03 (UTC) (edited on 2022-10-13 02:31 (UTC) by missingSleepDeps)

"configure: error: found development files for Guile 3.0, but /usr/bin/guile has effective version 2.2"

(pasting in the "prepare()..." and changing the "./configure" line didn't work)

pnorcks commented on 2022-10-02 21:13 (UTC)

What was the reason for removing the --with-guile-site configure flag in guile-lib-0.2.7-2 (currently the latest commit)?

I am asking about this because my package guile-dsv depends on guile-lib, and it fails to build at the moment. When I build/install guile-lib using --with-guile-site, guile-dsv builds cleanly again.

lantw44 commented on 2021-06-14 14:36 (UTC) (edited on 2021-06-14 18:02 (UTC) by lantw44)

Can it be modified to install files in the standard locations instead of its own /usr/lib/guile-lib directory? This can be done by adding 'moddir=/usr/share/guile/site/2.2 godir=/usr/lib/guile/2.2/site-ccache' to make command line. Currently Guix 1.3.0 cannot find guile-lib even if the package is installed.

checking if (htmlprag) exports `%strict-tokenizer?'... no
configure: WARNING: The Guile-Lib requirement was not satisfied (>= 0.2.7);
Some features such as the Go importer will not be usable.

However, values recorded in the .pc file doesn't change if we modify the installation path by make command line.

flatwhatson commented on 2019-11-05 12:31 (UTC) (edited on 2019-11-05 12:31 (UTC) by flatwhatson)

The following patch allows this to build properly for guile 2.2.

diff --git a/PKGBUILD b/PKGBUILD
index a1f409e..228ae2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ md5sums=('6457b08133e4baa54a438a11b18e9c30')

 build(){
   cd ${pkgname}-${pkgver}
-  ./configure --prefix=/usr
+  GUILE=/usr/bin/guile ./configure --prefix=/usr
   make
 }

early_adopter commented on 2019-05-11 12:31 (UTC)

Adding this clause to PKGBUILD allows it to compile

prepare() {
  cd ${pkgname}-${pkgver}
  sed -i 's/ 2.2/ /g' configure
}

exaos commented on 2019-03-28 15:05 (UTC)

failed to build due to the following error:

configure: error: found development files for Guile 2.2, but /usr/bin/guile2.0 has effective version 2.0

dpriskorn commented on 2018-11-20 12:16 (UTC)

fails to build. needs guile 2.2 it seems

beej commented on 2017-03-12 05:46 (UTC)

0.2.5 is now available upstream.