Package Details: hugin-hg r8405.de3609447749-1

Git Clone URL: https://aur.archlinux.org/hugin-hg.git (read-only, click to copy)
Package Base: hugin-hg
Description: A frontend to the panorama-tools
Upstream URL: http://hugin.sourceforge.net/
Licenses: GPL
Conflicts: hugin
Provides: hugin
Submitter: stativ
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 12
Popularity: 0.000000
First Submitted: 2010-05-20 19:15 (UTC)
Last Updated: 2022-01-23 22:10 (UTC)

Required by (12)

Sources (1)

Latest Comments

1 2 Next › Last »

tmladek commented on 2022-07-25 15:49 (UTC)

Build failed for me because it couldn't find wxwidgets, had to change the following line:

    -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3

to just

    -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config

FabioLolix commented on 2022-03-27 14:49 (UTC)

On an updated system and a fresh build (r8451) I don't have that problem

marcocurreli commented on 2022-03-27 14:20 (UTC) (edited on 2022-03-27 14:20 (UTC) by marcocurreli)

Hugin crashes with this message:

Hugin Error initializing GLEW Fast preview
Fast preview window can not be opened

malacology commented on 2021-06-15 16:01 (UTC)

I don't know it this package is out of date. But it seems that the dependences are not great enough

depends=('boost' 'libtiff' 'libpano13' 'libpng' 'openexr' 'vigra' 'libkexiv2' 'glew' 'gettext' 'sqlite' 'lcms2' 'wxgtk3' 'glu' 'libxi' 'libxmu' 'jp2a' 'libjpeg-turbo' 'perl-image-exiftool>=9.09' 'enblend-enfuse>=3.2')
# jp2a and  libjpeg-turbo for "libjpg the JPEG library"
makedepends=('python>=3.0' 'cmake' 'swig>=2.0.4')
optdepends=('lapack' 'fftw')

I'm not sure about the details but it should be updated as earlier comments.

jojo4u commented on 2021-01-23 14:07 (UTC)

Here the the provides drop: https://github.com/archlinux/svntogit-packages/commit/71ee17d529f8e0dc5c44d2fffb0dfa69b71daa0b

jojo4u commented on 2021-01-23 14:02 (UTC)

This package depends on wxgtk but the current extra wxgtk packages are called wxgtk3 and wxgtk2 by now with no "provides wxgtk".

stativ commented on 2015-11-09 19:20 (UTC)

DrMartinus: fixed

DrMartinus commented on 2015-11-08 17:44 (UTC)

I get the following error when trying to install the package: CMake Error at CMakeLists.txt:7 (message): In-source builds are not allowed. Any help?

grayich commented on 2014-07-06 06:25 (UTC)

mb add in depends libpano-hg ?

stativ commented on 2013-05-22 08:30 (UTC)

Until libpano13 2.9.19 is out you need to use libpano-hg