Package Details: idjc 0.8.17-3

Git Clone URL: https://aur.archlinux.org/idjc.git (read-only)
Package Base: idjc
Description: Powerful client for individuals interested in streaming live radio shows
Upstream URL: http://idjc.sourceforge.net/
Licenses: GPL2
Conflicts: idjc-git
Submitter: None
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 44
Popularity: 0.000001
First Submitted: 2006-08-31 13:17
Last Updated: 2018-08-28 13:02

Latest Comments

« First ‹ Previous 1 2 3

killermoehre commented on 2011-03-11 09:19

The python-dep should be python2 according to http://idjc.sourceforge.net/install_build.html

Anonymous comment on 2010-10-24 15:56

Hi GraveDigger,
thank you, i just included your ptch and credited you inside the PKGBUILD for it. Thank you.

Anonymous comment on 2010-10-20 17:58

a tarball for the lazy people: http://grave.mount.at/stuff/idjc_fixed.tar.gz

Anonymous comment on 2010-10-20 17:50

hi!

the building with python2/python3 fails, because the mutagen package is only for python2, and not for python3, at least it seems to me because telling the configure script to explicitely use python2 made the build succeed.

here's the modified PKGBUILD:
---------------------------------------------------------------------------------------------------------
# Contributor: Tobias Luther <tobias [at] tonstrom [dot] de>

pkgname=idjc
pkgver=0.8.4
pkgrel=3
pkgdesc="Graphical DJ Console aimed mainly at internetradio streaming via shout- or icecast. It also includes a jingle-player, advanced options for controling the microphone's sound and voip-integration."
arch=(i686 x86_64)
url="http://idjc.sourceforge.net/"
depends=('python' 'jack' 'pygtk' 'lame' 'mutagen' 'flac' 'libsamplerate' 'libshout' 'vorbis-tools' 'libsndfile' 'ffmpeg' 'libmad' 'speex')
optdepends=('qjackctl: quite popular qt based graphical frontend for jack')
makedepends=('pkgconfig')
source=(http://downloads.sourceforge.net/idjc/idjc-$pkgver.tar.gz idjc_0.8.4_configure.patch)
md5sums=('e2b6fb984c815bebe7604ebf701f756e' '6ae4c92200f1364d7975bde7b2f9fe55')
license=('GPLv3')

build() {
cd $startdir/src/$pkgname-$pkgver
patch -p1 < ${srcdir}/idjc_0.8.4_configure.patch
PYTHON=/usr/bin/python2 ./configure --prefix=/usr CFLAGS="-O2"
make -j4 || return 1
make DESTDIR=$pkgdir install
}
---------------------------------------------------------------------------------------------------------


and the mentioned patchfile:
---------------------------------------------------------------------------------------------------------
diff -Naur idjc-0.8.4/configure idjc-0.8.4.new/configure
--- idjc-0.8.4/configure 2010-10-07 15:00:07.000000000 +0200
+++ idjc-0.8.4.new/configure 2010-10-20 19:30:48.000000000 +0200
@@ -5349,7 +5349,7 @@

{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for mutagen" >&5
$as_echo_n "checking for mutagen... " >&6; }
-python -c "import mutagen" &>/dev/null
+$PYTHON -c "import mutagen" &>/dev/null
if test $? -ne 0 ; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
---------------------------------------------------------------------------------------------------------

Anonymous comment on 2010-10-12 20:55

mutagen is a dependency (see list above). python-mutagen is just another name, for example debian / ubuntu are using it. i re-checked on several machines & architectures and it builds ok. please re-check your installation and try again. did mutagen install correctly?

robertfoster commented on 2010-10-10 16:38

configure: error: required dependency (mutagen / python-mutagen) is missing