Package Details: ikiwiki 3.20160509-1

Git Clone URL: https://aur.archlinux.org/ikiwiki.git (read-only)
Package Base: ikiwiki
Description: wiki/blog compiler
Upstream URL: http://ikiwiki.info
Licenses: GPL
Submitter: None
Maintainer: kritztopf
Last Packager: kritztopf
Votes: 33
Popularity: 0.081334
First Submitted: 2007-08-01 15:41
Last Updated: 2016-07-10 11:54

Latest Comments

BoySka commented on 2016-08-29 14:19

new version:
pkgver=3.20160728
md5sums=('ca7ab38f1b5c9a1fafb34ee95f389c9b')

axil42 commented on 2016-07-07 06:00

New source at https://packages.debian.org/unstable/source/ikiwiki

version=3.20160509
md5sum='22fe66e77d6062ddf68ef5e9ec184dc0'

aude commented on 2016-06-30 15:03

This package also depends on perl-cgi.

Without, the CGI throws this error message:
Error: Can't locate CGI.pm in @INC (you may need to install the CGI module) (@INC contains: ...) at (eval 53) line 2. BEGIN failed--compilation aborted at (eval 53) line 2.

idim commented on 2015-10-09 08:22

Hey! I'd like to thank you for raising back perl-cgi-formbuilder from the dead. I would have struggled to do so myself.
I just launched an ikiwiki installation and it all went smoothly, no error encountered while building the package and it's dependencies. Thumbs up!

kritztopf commented on 2015-10-05 15:01

There is: create it yourself :) That's what I did now, found some time to do it. It install just fine, but the ikiwiki installation fails.

I'm not doing a lot of stuff with ikiwiki, so maybe one of you has an idea how to handle that checking error?

It's this error:
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^\$ENV{ <-- HERE PATH}="(.*)";/ at ./pm_filter line 31.
./pm_filter /usr 3.20150614 /usr/share/perl5/vendor_perl < ikiwiki.in > ikiwiki.out

idim commented on 2015-10-05 06:22

Is there a workaround for perl-cgi-formbuilder missing from AUR?

Francois_B commented on 2015-09-14 00:51

perl-cgi-formbuilder is not available I think.

edrex commented on 2015-08-25 15:22

For anyone hitting a build error when upgrading, you likely need to reinstall perl-yaml-libyaml from AUR. It needs to be rebuilt for newest perl.

alkino commented on 2015-08-20 22:01

perl-cgi-formbuilder is not in AUR

eigengrau commented on 2015-07-29 12:09

This also seems to depend on perl-cgi.

All comments