Package Details: inkscape-git 1:1.0+devel.r4386.g0a5dc27633-1

Git Clone URL: https://aur.archlinux.org/inkscape-git.git (read-only)
Package Base: inkscape-git
Description: An Open Source vector graphics editor, using SVG file format, from git master
Upstream URL: https://gitlab.com/inkscape/inkscape
Licenses: GPL, LGPL
Conflicts: inkscape
Provides: inkscape
Submitter: haawda
Maintainer: haawda (bartus)
Last Packager: haawda
Votes: 6
Popularity: 0.341257
First Submitted: 2017-06-10 19:46
Last Updated: 2019-04-28 15:27

Required by (89)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

haawda commented on 2018-11-14 21:06

!makeflags dropped

bartus commented on 2018-11-14 15:54

@haawda: can you drop !makeflags from options - single-threaded build took ages ;/

haawda commented on 2018-11-09 05:47

thanks, applied, but I had to turn off dbus support.

z3ntu commented on 2018-11-08 20:29

diff --git a/PKGBUILD b/PKGBUILD
index bb25b9b..2ae6c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,13 +31,9 @@ pkgver() {

 prepare() {
   cd "$_gitname"
-  sed -i 's|"python"|"python2"|g' src/main.cpp
   find share -type f -name "*.py" -exec \
-       sed -i '1s|/usr/bin/env python\>|/usr/bin/env python2|g' {} \;
-  sed -i '1s|/usr/bin/env python3\>|/usr/bin/env python2|g' CMakeScripts/cmake_consistency_check.py
+       sed -i '1s|/usr/bin/env python$|/usr/bin/env python2|g' {} \;
   sed -i 's|"python" },|"python2" },|g' src/extension/implementation/script.cpp
-  sed -i 's|"python"|"python2"|g' src/main.cpp
-  sed -i -e 's|GBool|bool|g' -e 's|gTrue|true|g' -e 's|gFalse|false|g' src/extension/internal/pdfinput/pdf-parser.{h,cpp}
 }

 build() {

This patch should get rid of outdated replacements (e.g. poppler patch is upstream, don't switch python3 scripts to python2)

bartus commented on 2018-11-04 21:57

poppler=0.71.0 introduces some naming scheme changes, need a patch or sed substitution.

sed -i -e 's|GBool|bool|g' -e 's|gTrue|true|g' -e 's|gFalse|false|g' src/extension/internal/pdfinput/pdf-parser.{h,cpp}

ooo commented on 2018-09-11 23:56

Build fails on prepare:

==> Starting prepare()...
sed: can't read share/*/test/*.py: No such file or directory
==> ERROR: A failure occurred in prepare().
Aborting...

If you comment out the sed line, build finishes succesfully. Although there's also a warning about reference to $srcdir:

==> WARNING: Package contains reference to $srcdir
usr/lib/inkscape/libinkscape_base.so

haawda commented on 2018-06-11 19:56

done

linkmauve commented on 2018-06-10 23:09

Hi, the WITH_GNOME_VFS option has been removed in commit 5433ac0513099a4a12caba0cda8a2a9d30e13a22, please remove it from the build() function.

z3ntu commented on 2018-05-12 21:46

libmagick6 is a runtime dependency otherwise you get "inkscape: error while loading shared libraries: libMagick++-6.Q16HDRI.so.8: cannot open shared object file: No such file or directory"

bm456 commented on 2018-01-30 17:41

it has a build error

this will fix it https://p.teknik.io/OtxSe