Package Details: kakoune-git 2020.09.01_r231_gce96c3f2-1

Git Clone URL: https://aur.archlinux.org/kakoune-git.git (read-only, click to copy)
Package Base: kakoune-git
Description: Multiple-selection, UNIX-flavored modal editor
Upstream URL: https://github.com/mawww/kakoune
Licenses: custom:UNLICENSE
Conflicts: kakoune
Provides: kakoune=2020.09.01_r231_gce96c3f2
Submitter: galaux
Maintainer: lenormf
Last Packager: lenormf
Votes: 39
Popularity: 0.002236
First Submitted: 2013-12-18 16:01
Last Updated: 2020-12-09 09:16

Dependencies (9)

Required by (14)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

lenormf commented on 2020-12-09 09:19

Thank you, the package manifest has been modified. I've also verified that it worked with kak-snippets-git.

Ordoviz commented on 2020-12-08 07:05

@lenormf I tried it and can confirm that pacman treats 2020.09.01_r192_g411bf736 >= 2019.07.01 as true.

lenormf commented on 2020-12-07 07:52

Ordoviz, the version number for kakoune-git has a different format, are you sure kak-snippets-git is going to resolve 2020.01.16_r186_g60154300 as 2020.01.16?

Ordoviz commented on 2020-11-14 09:47

Consider replacing provides=('kakoune') with provides=("kakoune=$pkgver"). On install I got the error: “removing kakoune breaks dependency 'kakoune>=2019.07.01' required by kak-snippets-git”

lenormf commented on 2020-01-27 07:00

Trying cleaning the cache of whatever AUR package manager you're using.

hisacro commented on 2020-01-26 18:56

/bin/ld: .commands.opt.o: file not recognized: file truncated collect2: error: ld returned 1 exit status make: *** [Makefile:108: kak.opt] Error 1 ==> ERROR: A failure occurred in build(). Aborting...

not sure why I'm getting this error

maximbaz commented on 2019-01-22 07:04

The wiki doesn't say the base-devel package has to be installed fully:

This is a fair argument :) There was also another line "Note: Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as dependencies explicitly.", but I agree it wasn't quite clear.

To be consistent all the way down, I adapted the wiki to say "Ensure the base-devel package group is installed in full".

lenormf commented on 2019-01-22 06:53

The wiki doesn't say the base-devel package has to be installed fully:

Ensure the base-devel package group is installed

But since the PKGBUILD does expect users to have gcc installed, which is part of this package group and is not listed in the PKGBUILD, I'm removing pkgconf from the build dependencies in the name of consistency.

Note that neither cat nor uname are necessary to build the project ;)

maximbaz commented on 2019-01-21 07:38

Unfortunately you are missing the point of AUR, it's a repo of PKGBUILDs that follow certain conventions, one of them being the expectation of base-devel group being installed in full. The wiki I referred you to is the place where this is documented, and it clearly says "Before using AUR, make sure to install base-devel group".

Notice that you aren't ensuring that make is installed for example, or cat or uname for that matter, so your PKGBUILD does have some expectations on the users' system, it's just that your expectations are different from the ones that people commonly agreed on when using AUR.

lenormf commented on 2019-01-21 07:05

There's a possibility that pkg-config wouldn't be installed on a given system (because you can choose not to install it as part of base-devel, Docker image or not), so it has to be in the build dependencies.

Also the entire point of PKGBUILD is to make sure everything required to build the package is installed, I don't see how it has any impact on "quality". Expecting users to "read the wiki" instead of running a command that will produce a package without any other kind of interaction is a terrible idea.