Package Details: kdepim-runtime-etesync-git v20.08.1.r218.g05354bbd3-1

Git Clone URL: https://aur.archlinux.org/kdepim-runtime-etesync-git.git (read-only, click to copy)
Package Base: kdepim-runtime-etesync-git
Description: Extends the functionality of kdepim (with etesync modules)
Upstream URL: https://kontact.kde.org
Licenses: GPL, LGPL, FDL
Submitter: tasn
Maintainer: tasn
Last Packager: tasn
Votes: 3
Popularity: 1.74
First Submitted: 2020-08-20 11:32
Last Updated: 2020-11-14 07:27

Latest Comments

bennypr0fane commented on 2020-11-07 21:07

I was able to build it without a hitch now, thanks!

tasn commented on 2020-11-07 08:16

Try now, it should now work! I changed the package to be a little different. It now only builds the etesync module so it doesn't require git versions for all of the other deps.

Note: may require the a manual step though. You may need to install the original kde-pim package before installing this new version. Sorry for the break.

tasn commented on 2020-11-07 07:57

It looks like it's now depending on a new version of kimap that's not yet available in Arch. I contacted the maintainer of the etesync module, maybe there's a way around it. Will update once I hear back.

bennypr0fane commented on 2020-11-06 22:15

Got make process off the ground this time, but now it's build(): [ 69%] Built target akonadi_maildir_resource make: *** [Makefile:149: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... error making: kdepim-runtime-etesync-git Mailing you longer output for diagnosis. About the package name: I read it wrong, sorry, my bad!

tasn commented on 2020-11-06 19:20

Not sure what you mean about the package name not including the version number. The only thing that's part of the version is the -git, which is the correct thing to do for git based packages.

As for the build issue: fixed.

bennypr0fane commented on 2020-11-06 18:58

I get the following build error:

==> Making package: kdepim-runtime-etesync-git v20.08.1.r196.ga0a134809-1 (Fri Nov 6 19:52:36 2020) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Updating kdepim-runtime-etesync git repo... Fetching origin warning: redirecting to https://invent.kde.org/pim/kdepim-runtime.git/ -> Found 0001-XXX-Ease-version-requirements.patch ==> Validating source files with sha512sums... kdepim-runtime-etesync ... Skipped 0001-XXX-Ease-version-requirements.patch ... Skipped ==> Removing existing $srcdir/ directory... ==> Extracting sources... -> Creating working copy of kdepim-runtime-etesync git repo... Cloning into 'kdepim-runtime-etesync'... done. ==> Starting prepare()... error: patch failed: CMakeLists.txt:1 error: CMakeLists.txt: patch does not apply ==> ERROR: A failure occurred in prepare(). Aborting... error making: kdepim-runtime-etesync-git