Package Details: kicad-git 5.99.0.r6895.gbd63c018c9-1

Git Clone URL: https://aur.archlinux.org/kicad-git.git (read-only, click to copy)
Package Base: kicad-git
Description: Electronic schematic and printed circuit board (PCB) design tools
Upstream URL: https://kicad.org/
Licenses: GPL
Conflicts: kicad, kicad-bzr
Provides: kicad
Submitter: Chocobo
Maintainer: nickoe
Last Packager: nickoe
Votes: 67
Popularity: 0.162932
First Submitted: 2015-10-08 16:39
Last Updated: 2021-10-20 18:18

Pinned Comments

nickoe commented on 2021-05-23 11:09

@haawda, thank you for testing, but I currently think the right thing to do is to get community/python-wxpython downgraded.

See https://bugs.archlinux.org/task/70908

Latest Comments

1 2 3 4 5 6 ... Next › Last »

nickoe commented on 2021-10-23 19:50

@electro707, I am not awareof ny verison bump requirement from upstream, what I think you are facing is that you may have installed a wxpython version that requries wx 3.1, maybe oyu insalled wxpython 4.1?

electro707 commented on 2021-10-23 04:14

Looks like, as of 2021-10-23, that KiCad requires WxWidgets 3.1.5:

CMake Error at /usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find wxWidgets: Found unsuitable version "3.0.5", but required is
  at least "3.1.5" (found
  -pthread;;;-lwx_gtk3u_gl-3.0;-lwx_gtk3u_aui-3.0;-lwx_gtk3u_adv-3.0;-lwx_gtk3u_html-3.0;-lwx_gtk3u_core-3.0;-lwx_baseu_net-3.0;-lwx_baseu-3.0;-lwx_gtk3u_propgrid-3.0;-lwx_baseu_xml-3.0;-lwx_gtk3u_stc-3.0;-lwx_gtk3u_richtext-3.0)
Call Stack (most recent call first):
  /usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:592 (_FPHSA_FAILURE_MESSAGE)
  CMakeModules/FindwxWidgets.cmake:1019 (find_package_handle_standard_args)
  CMakeLists.txt:876 (find_package)

But the non-AUR wxgtk3 package is using the stable wx release of 3.0.5

nickoe commented on 2021-10-20 18:18

@f0x52, yes, I have now updated it

f0x52 commented on 2021-10-20 12:22

as per https://forum.kicad.info/t/warning-avoid-all-links-to-kicad-pcb-org-use-kicad-org/31521 the upstream url should probably be changed to kicad.org

barabas commented on 2021-07-19 20:14

Getting some warnings from CMake:

CMake Warning:
  Manually-specified variables were not used by the project:

    BUILD_GITHUB_PLUGIN
    KICAD_SCRIPTING
    KICAD_SCRIPTING_ACTION_MENU
    KICAD_SCRIPTING_MODULES
    KICAD_SCRIPTING_PYTHON3
    KICAD_SCRIPTING_WXPYTHON_PHOENIX

These have been removed and ON by default. See this post on the mailing list.

greyltc commented on 2021-06-04 13:58

Hey, can you add -G Ninja to the cmake options and then change make to cmake --build . then the make install line can become DESTDIR="${pkgdir}" cmake --build . -- install

makes the build go brrr

nickoe commented on 2021-05-23 11:09

@haawda, thank you for testing, but I currently think the right thing to do is to get community/python-wxpython downgraded.

See https://bugs.archlinux.org/task/70908

haawda commented on 2021-05-23 01:30

I needed to use wxgtk3-dev from AUR instead of WXGTK3 and the fowllowing patch to build.

diff --git a/PKGBUILD b/PKGBUILD
index 0b23d76..36f51ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,6 +31,7 @@ build() {
     -DCMAKE_INSTALL_LIBDIR=lib \
     -DKICAD_USE_OCE=OFF \
     -DKICAD_USE_OCC=ON \
+    -DKICAD_USE_EGL=ON \
     -DBUILD_GITHUB_PLUGIN=ON \
     -DKICAD_SCRIPTING=ON \
     -DKICAD_SCRIPTING_MODULES=ON \

alfrede commented on 2021-05-17 05:49

@Nick for the Problem that Knapik talked about, i had the same Problem with the kicad-nightly package and DX-Mon said to me that i had to downgrade the wxPython Package to Version 4.0.7.2-5. Here the Link to the Package.

https://aur.archlinux.org/pkgbase/kicad-nightly/

@kanpik, perhaps it helps you.

h2obrain commented on 2021-05-16 16:36

@knapik For some reason python-wxpython-4.1.1-1 reports 3.1.5 as the wxWidgets_version

Python 3.9.5 (default, May 12 2021, 17:14:51) 
[GCC 10.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
>>> wx.wxWidgets_version
'wxWidgets 3.1.5'
>

Adding wxWidgets_version = 'wxWidgets 3.0.5' to the end of /usr/lib/python3.9/site-packages/wx/__init__.py made it (start to) build, but this is obviously not a good solution. :)