Package Details: kile-git v3.0b2.r90.g5b83c2a0-2

Git Clone URL: https://aur.archlinux.org/kile-git.git (read-only, click to copy)
Package Base: kile-git
Description: A TeX/LaTeX frontend for KDE
Upstream URL: http://kile.sourceforge.net/
Keywords: editor latex
Licenses: GPL2
Conflicts: kile
Provides: kile
Replaces: kile-svn
Submitter: vnoel
Maintainer: dysphoria
Last Packager: dysphoria
Votes: 24
Popularity: 0.000000
First Submitted: 2010-11-16 10:39
Last Updated: 2020-04-20 06:57

Latest Comments

1 2 3 4 5 6 Next › Last »

Martchus commented on 2020-04-17 21:58

Thanks for updating. It seems the package needs qt5-script which is missing in the dependencies:

CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package):
  Could not find a package configuration file provided by "Qt5Script" with
  any of the following names:

    Qt5ScriptConfig.cmake
    qt5script-config.cmake

  Add the installation prefix of "Qt5Script" to CMAKE_PREFIX_PATH or set
  "Qt5Script_DIR" to a directory containing one of the above files.  If
  "Qt5Script" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  CMakeLists.txt:31 (find_package)


-- Configuring incomplete, errors occurred!

fclad commented on 2020-04-15 19:03

Hi, I am orphaning this package as I don't use Kile anymore!

fclad commented on 2017-06-30 14:25

Done. Thanks for your contribution!

Martchus commented on 2017-06-17 14:18

Dependency khtml is missing:

```
CMake Error at /usr/share/cmake-3.8/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find KF5 (missing: KHtml) (found suitable version "5.35.0",
minimum required is "5.11")
Call Stack (most recent call first):
/usr/share/cmake-3.8/Modules/FindPackageHandleStandardArgs.cmake:377 (_FPHSA_FAILURE_MESSAGE)
/usr/share/ECM/find-modules/FindKF5.cmake:110 (find_package_handle_standard_args)
CMakeLists.txt:37 (find_package)


-- Configuring incomplete, errors occurred!
```

sebsch commented on 2017-01-29 08:42

Having issues building this packet. Does anyone have a glue what is going so badly here?

/usr/lib/libKF5KHtml.so.5.30.0: undefined reference to `qt_version_tag@Qt_5.7'
/usr/lib/libKF5TextWidgets.so.5.30.0: undefined reference to `qt_version_tag@Qt_5.8'
/usr/lib/libKF5KHtml.so.5.30.0: undefined reference to `QIODevice::isTransactionStarted() const@Qt_5'
/usr/lib/libphonon4qt5.so.4: undefined reference to `QJsonObject::value(QLatin1String) const@Qt_5'
/usr/lib/libQt5TextToSpeech.so.5: undefined reference to `QJsonObject::contains(QLatin1String) const@Qt_5'
/usr/lib/libKF5KHtml.so.5.30.0: undefined reference to `QIcon::fromTheme(QString const&)@Qt_5'
/usr/lib/libKF5TextEditor.so.5.30.0: undefined reference to `QJsonValue::toString() const@Qt_5'
/usr/lib/libKF5KHtml.so.5.30.0: undefined reference to `QListWidget::setSelectionModel(QItemSelectionModel*)@Qt_5'
/usr/lib/libKF5KHtml.so.5.30.0: undefined reference to `QString::resize(int, QChar)@Qt_5'


fclad commented on 2017-01-14 16:28

@naund changed!

naund commented on 2017-01-14 11:06

please change the dependency from okular-git to okular>16.12.0

fclad commented on 2016-11-13 14:25

@prettyvanilla Thanks! I have updated the PKGBUILD

prettyvanilla commented on 2016-11-05 19:49

okular-frameworks-git has been deleted today, so the dependency needs to be changed to okular-git. Also, the install file shouldn't be needed anymore, as that is covered by hooks now.

fclad commented on 2015-11-14 13:37

@Spyhawk Sorry for this problem. I've just fixed the PKGBUILD. Please let me know if you have any problems.