Package Details: krita-git 5.3.0.prealpha.279.g8697e4bffc-2

Git Clone URL: https://aur.archlinux.org/krita-git.git (read-only, click to copy)
Package Base: krita-git
Description: A full-featured free digital painting studio. Git version.
Upstream URL: https://krita.org
Keywords: qt5
Licenses: GPL3
Conflicts: calligra-krita, krita, krita-il10n
Provides: krita
Submitter: sl1pkn07
Maintainer: AlfredoRamos
Last Packager: AlfredoRamos
Votes: 16
Popularity: 0.000002
First Submitted: 2015-10-11 13:38 (UTC)
Last Updated: 2023-12-30 06:07 (UTC)

Latest Comments

1 2 3 4 5 6 .. 9 Next › Last »

arojas commented on 2023-08-27 19:29 (UTC)

Please switch to the official repo https://invent.kde.org/graphics/krita instead of a semi-unsupported mirror.

greenhandzdl commented on 2023-06-23 10:35 (UTC)

-- Found KF5WindowSystem: /usr/lib/cmake/KF5WindowSystem/KF5WindowSystemConfig.cmake (found version "5.105.0") CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find KF5 (missing: CoreAddons GuiAddons) (found suitable version "5.105.0", minimum required is "5.44.0") Call Stack (most recent call first): /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600 (_FPHSA_FAILURE_MESSAGE) /usr/share/ECM/find-modules/FindKF5.cmake:93 (find_package_handle_standard_args) CMakeLists.txt:394 (find_package)

-- Configuring incomplete, errors occurred! ==> ERROR: A failure occurred in build(). Aborting... -> error making: krita-git-exit status 4 -> Failed to install the following packages. Manual intervention is required: krita-git - exit status 4

Swiftloke commented on 2023-05-14 19:10 (UTC)

+1 to the below comment. One must install all of immer-git, zug-git, libunibreak and lager-git. Additionally, libhttpserver-git is broken and must be installed manually.

Furthermore, CMake was not able to find xsimd during compilation, so usage of it was disabled, despite xsimd being a dependency of this package.

WORMSTweaker commented on 2023-03-25 00:54 (UTC) (edited on 2023-03-25 00:54 (UTC) by WORMSTweaker)

Seems it's missing the immer-git, zug-git, libunibreak and lager-git dependencies now

lager-git itself seems to depend on libhttpserver-git but the package is broken for me and didn't correctly clone the project from github (Wrong URL?)

Only after I manually built and installed libhttpserver-git did everything compile correctly

AlfredoRamos commented on 2023-01-01 23:02 (UTC)

@electricprism I just updated the dependency list, so xsimd support should be included.

electricprism commented on 2022-12-28 08:19 (UTC)

Is this still up to date? Is it compiled with xsimd support?

AlfredoRamos commented on 2022-06-16 15:13 (UTC)

@zlfn: Nightly builds and builds from source are two different things.

In my opinion krita-next-git should be deleted, since it's the same as this package (krita-git), does not differ from this build in any way (different features, patches, etc.), and this one follows the naming convention guidelines.

https://wiki.archlinux.org/title/VCS_package_guidelines#Guidelines

However that's a decision a TU should make.

zlfn commented on 2022-06-16 00:49 (UTC) (edited on 2022-06-16 00:49 (UTC) by zlfn)

I have something to discuss.
Krita's pre alpha build is split into two branches.
Krita-Plus with only new bug fixes and
Krita-Next with new features.

Krita-Plus is based on the krita/5.1 branch of the krita repository.
Krita-Next is based on the master branch.
These are built daily by Jenkins and distributed in .appimage format.

I uploaded two VCS packages based on two different branches to use them in Arch. (krita-plus-git, krita-next-git)

And I just noticed that the content provided by krita-git and the content provided by krita-next-git are exactly the same.

I think these two should be merged. Can one package have two names? Or is there a naming convention to use in this case?
I would like to keep the krita-next naming if possible.

zlfn commented on 2022-06-16 00:06 (UTC)

@AlfredoRamos: Sorry, I didn't know.

AlfredoRamos commented on 2022-06-15 22:36 (UTC)

@zlfn: The package is not outdated as it always builds the latest available version from source.

So unless the package is missing a dependency or the build fails, please refrain to marking the package as out-of-date.

Read the note about VCS packages in the wiki:

https://wiki.archlinux.org/title/Arch_User_Repository#Flagging_packages_out-of-date

I've unflagged it as out-of-date as it builds the latest version perfectly fine as of today.