Package Details: libgnomeprint 2.18.8-10

Git Clone URL: https://aur.archlinux.org/libgnomeprint.git (read-only, click to copy)
Package Base: libgnomeprint
Description: Printing routines for GNOME
Upstream URL: http://www.gnome.org/
Keywords: cups gnome libgnomeprint printing
Licenses: GPL, LGPL
Conflicts: libgnomeprint-cups
Replaces: libgnomeprint-cups
Submitter: None
Maintainer: not_anonymous
Last Packager: not_anonymous
Votes: 148
Popularity: 0.000003
First Submitted: 2011-12-05 15:28 (UTC)
Last Updated: 2022-02-19 17:11 (UTC)

Latest Comments

not_anonymous commented on 2022-02-19 20:34 (UTC)

Actually its not listed in either.

Popolon commented on 2022-02-19 19:17 (UTC)

I believe bzip2 is a makedepends instead of a depends.

not_anonymous commented on 2022-02-19 17:11 (UTC) (edited on 2022-02-20 00:03 (UTC) by not_anonymous)

Updated...PLUS, I "fixed" addinclude by creating a new package; addinclude-git to solve the problem of a not working addinclude.pkg

Popolon commented on 2020-09-28 23:44 (UTC) (edited on 2020-09-28 23:46 (UTC) by Popolon)

I added a patch, on configure.in to make it compile with recent version of freetype2 (use pkg-config to retrieve lib/include dirs, instead of it's own freetype-config).

Disable doc to make the package build, if someone have a solution, he can patch it. I just adopted the package, corrected it and disowned it. At least it works for dependencies.

phansel commented on 2020-01-17 18:20 (UTC)

The freetype-config and gtkdoc-scan UTF-8 parsing issue is still a problem.

tallero commented on 2018-12-20 05:55 (UTC) (edited on 2018-12-20 18:42 (UTC) by tallero)

@TPXP: Here is the bug in freetype2 build

You need to recompile freetype2 with the option --enable-freetype-config to compile libgnomeprint. You can find the PKGBUILD to patch here

You also have to add the --enable-gtk-doc=no option to the configure of libgnomeprint PKGBUILD.

An updated PKGBUILD for libgnomeprint is here

TPXP commented on 2018-10-24 12:28 (UTC)

Looks like something is broken with Freetype :

configure: error: You need FreeType2 (freetype-devel v 2.x package) for this version of libgnomeprint

The freetype2 package is installed on my system. I tried installing lib32-freetype2 but still no luck :-/

Humble_Panda commented on 2014-07-04 09:41 (UTC)

Fair enough, that makes sense. Thanks biinari

biinari commented on 2014-07-04 09:31 (UTC)

Looks like bison is now in the base-devel group. I'm not sure how long it's been there but the general rule is to not mention dependencies that are in base-devel.

Humble_Panda commented on 2014-07-04 06:44 (UTC)

The problem has been fixed and http://sources.gentoo.org is now working again. Moreover, I noticed bison is not a dependency listed on this package's dependencies list. Wouldn't it better to include bison to the list? Cheers,

biinari commented on 2014-07-03 17:06 (UTC)

Looks like the server outage for sources.gentoo.org has been reported to gentoo already https://bugs.gentoo.org/show_bug.cgi?id=515828

Humble_Panda commented on 2014-07-02 05:58 (UTC)

It's been now several day that I'm getting an error while trying to update this package. It always says "failed to connect to sources.gentoo..." In fact, http://sources.gentoo.org doesn't even work :( Cheers

pinball-fixer commented on 2014-06-29 15:07 (UTC)

No probs xyproto, I'm glad it worked out!

xyproto commented on 2014-06-26 14:15 (UTC)

The Gentoo patch worked out. Removed the make dependency on bison27. Thanks, pinball-fixer.

xyproto commented on 2014-06-23 15:33 (UTC)

Hi pinball-fixer. The patch you link to might work out. I'll give it a shot.

pinball-fixer commented on 2014-06-23 14:06 (UTC)

I've got Bison 3 installed on my system (due to having Wine installed) and need libgnomeprint installed to make KiCad print. As Bison 3 conflicts with Bison27, I am wondering if the patch below will work on Arch as well? I have no idea how to test this, so I am hoping someone here can, or let me know how to so I can try for myself and report back. Any help would be greatly appreciated. http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-bison3.patch?content-type=text%2Fplain&revision=1.1

xyproto commented on 2013-12-22 12:04 (UTC)

Thanks, josephgbr. Updated the package.

rafaelff commented on 2013-12-20 17:10 (UTC)

Compilation fails when it expects to find some headers provided by freetype. This issue was reported and fixed in the bug BGO#719592 [1]. For your convenience, here is the PKGBUILD with the patch (from the the bug report) applied and the pkgrel bump. PKGBUILD - http://paste.archlinux-br.org/2226 patch-freetype-2.5.1.diff - http://paste.archlinux-br.org/2225 [1] https://bugzilla.gnome.org/show_bug.cgi?id=719592

buzzqw commented on 2013-11-21 14:21 (UTC)

with new bison2.7 the compilation is working thanks! BHH

buzzqw commented on 2013-11-20 13:42 (UTC)

i686 thanks xyproto! BHH

xyproto commented on 2013-11-20 11:38 (UTC)

buzzqw, the package builds and installs just fine here (x86_64). Are the packages on your system up to date? Are you on i686 or x86_64? Anyone else have the same issue as buzzqw?

korrode commented on 2013-11-20 00:57 (UTC)

Sorry guys, never knew anything other than my wine-stable package referenced bison27. I've re-uploaded and disowned it. All yours.

xyproto commented on 2013-11-19 11:22 (UTC)

buzzqw, not on the Arch Linux installation I currently have access to. If you want to adopt the package and look at it, I will happily orphan it.

buzzqw commented on 2013-11-19 11:13 (UTC)

but bison2.7 is already installed BHH

xyproto commented on 2013-11-19 11:01 (UTC)

bison27 (make dependency of this package) has been removed from AUR, but I asked for it to be uploaded again (ref aur-general). Unflagging as out of date, as there has been no new releases of libgnomeprint since 2010-09-28. Will look at the package again once bison27 is in AUR.

buzzqw commented on 2013-11-14 14:27 (UTC)

[code]==> libgnomeprint dependencies: - pango (already installed) - libart-lgpl (already installed) - libxml2 (already installed) - libgnomecups (already installed) - libgcrypt (already installed) - bzip2 (already installed) - intltool (already installed) - pkgconfig (already installed) - addinclude (already installed) - bison27 (already installed)[/code] .... [code]gcc: error: grammar.tab.c: No such file or directory gcc: fatal error: no input files compilation terminated. Makefile:611: recipe for target 'grammar.tab.lo' failed make[3]: *** [grammar.tab.lo] Error 1 make[3]: Leaving directory '/tmp/yaourt-tmp-root/aur-libgnomeprint/src/libgnomeprint-2.18.8/libgnomeprint' Makefile:690: recipe for target 'all-recursive' failed make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory '/tmp/yaourt-tmp-root/aur-libgnomeprint/src/libgnomeprint-2.18.8/libgnomeprint' Makefile:370: recipe for target 'all-recursive' failed make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory '/tmp/yaourt-tmp-root/aur-libgnomeprint/src/libgnomeprint-2.18.8' Makefile:297: recipe for target 'all' failed make: *** [all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build libgnomeprint. ==> Restart building libgnomeprint ? [y/N][/code] not compiling BHH

xyproto commented on 2013-09-11 12:22 (UTC)

Updated the PKGBUILD. It compiles again now (by using an older version of bison).

xyproto commented on 2013-09-10 09:44 (UTC)

@Nareto, thanks, will look at it.

Nareto commented on 2013-09-09 13:53 (UTC)

I get this error: http://pastebin.com/DJTPZV2E

xyproto commented on 2012-09-19 09:16 (UTC)

jorgicio, you must install "base-devel" before trying to install any package from AUR. This is expected of the users, and also mentioned in my comment below. See: https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

jorgicio commented on 2012-09-18 23:56 (UTC)

Please, add "flex" as a makedependency. Without that package, I can't compile. Thanks.

onny commented on 2012-02-20 10:54 (UTC)

@trontonic: Surprisingly, I also had to manually install 'flex' as dependency. Maybe it got removed after I installed the multilib-version of some important base-devel applications.

xyproto commented on 2011-12-08 15:10 (UTC)

Hi, both bison and flex are in the base-devel group. base-devel is not supposed to be included in the makedepends array. See: https://wiki.archlinux.org/index.php/PKGBUILD#makedepends and https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

max-k commented on 2011-12-08 14:55 (UTC)

Hi, could you add bison and flex to makedepends ? Thx

xyproto commented on 2011-12-07 11:14 (UTC)

Updated the dependencies.

xyproto commented on 2011-12-06 08:51 (UTC)

Adopted.

commented on 2011-12-05 16:48 (UTC)

You should install base-devel, those packages are never in makedepends.

matthiaskrgr commented on 2011-12-05 16:16 (UTC)

I think you miss a dependency checking for unistd.h... (cached) yes checking for sys/param.h... yes checking for getpagesize... yes checking for working mmap... yes checking locale.h usability... yes checking locale.h presence... yes checking for locale.h... yes checking for LC_MESSAGES... yes checking libintl.h usability... yes checking libintl.h presence... yes checking for libintl.h... yes checking for ngettext in libc... yes checking for dgettext in libc... yes checking for bind_textdomain_codeset... (cached) yes checking for msgfmt... (cached) /usr/bin/msgfmt checking for dcgettext... yes checking if msgfmt accepts -c... yes checking for gmsgfmt... (cached) /usr/bin/msgfmt checking for xgettext... (cached) /usr/bin/xgettext checking for gtkdoc-mkdb... true checking gtk-doc version (1.18) >= 0.9... yes checking for db2html... false checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for GP_F... yes checking for glib-genmarshal... /usr/bin/glib-genmarshal checking for cos in -lm... yes checking for freetype-config... /usr/bin/freetype-config configure: checking for sufficiently new FreeType (at least 2.0.5) checking for FT_Get_Postscript_Name in -lfreetype... yes checking for papiJobCreate in -lpapi... no checking for CUPS... yes checking for CUPS libraries version >= 1.1.20... Found version 1.5.0 checking for LIBGNOMECUPS... yes checking for deflateEnd in -lz... yes checking zlib.h usability... yes checking zlib.h presence... yes checking for zlib.h... yes checking for bison... no configure: error: Could not find bison ==> ERROR: A failure occurred in build(). Aborting...