Package Details: lighttpd2-git 1556.3a4698d-1

Git Clone URL: https://aur.archlinux.org/lighttpd2-git.git (read-only)
Package Base: lighttpd2-git
Description: The new Lighty: A small, secure, scalable, flexible webserver
Upstream URL: http://redmine.lighttpd.net/wiki/lighttpd2/
Licenses: MIT
Conflicts: lighttpd2
Provides: lighttpd2
Submitter: bougyman
Maintainer: schlmm
Last Packager: schlmm
Votes: 8
Popularity: 0.000097
First Submitted: 2011-04-11 00:10
Last Updated: 2016-07-06 08:32

Latest Comments

schlmm commented on 2016-07-06 08:32

thx.
should be fixed

Torxed commented on 2016-07-05 13:30

Getting errors compiling, among other things complaining about "lua5.1" not being found.

pkg-config --libs lua returns:
-llua -lm

Here's the build output: https://gist.github.com/Torxed/fa6bd82d04bf5fb082b03f7c6705907f

Torxed commented on 2015-03-18 22:13

Hi.
And of course it's working now. Typically my kind of posts.
Oddly enough the latest git when I cloned it manually gave me "Unrecognized parameter --with-pid-dir=/run"

And the git repo is up now so the https is just a backup solution I guess.
Sorry for a misleading comment even tho it might come in handy in the future.

schlmm commented on 2015-03-17 12:29

Hello,
I dont have any issues, also the git repo seems to be up.
Could you paste your errors ?

Torxed commented on 2015-03-17 12:13

For whatever reason, the git appears to be down.
Also I'm having integrity/signature issues and parameter issues for configure.
Here's a work-around for the mean time.

Manual install:
git clone https://git.lighttpd.net/lighttpd/lighttpd2.git
cd lighttpd2/
./autogen.sh
./configure --prefix=/usr ... (!!!see PKGBUILD, but remove --with-pid-dir=/run!!!)
make
sudo make install
sudo mkdir -p /etc/lighttpd2
sudo sed -i -e 's/^docroot "\/var\/www";/docroot "\/srv\/http";/' contrib/lighttpd.conf
cd contrib
sudo cp lighttpd.conf angel.conf mimetypes.conf /etc/lighttpd2/
sudo cp systemd/lighttpd2.service /usr/lib/systemd/system/
cd ..
sudo mkdir -p /var/log/lighttpd2
cd ..
rm -rf lighttpd2
sudo groupadd www-data
sudo useradd -m -g www-data -s /usr/bin/nologin www-data

Then run the service with `sudo systemctl start lighttpd`.

schlmm commented on 2015-01-11 17:42

Hi,
lighttpd2 only compiles with lua 5.1 for me.
also i did the move from /usr/sbin to /usr/bin
in the newest git there is also a systemd service.
patch below:

--- /tmp/yaourt-tmp-schlmm/aur-lighttpd2-git/PKGBUILD 2014-02-25 21:59:21.000000000 +0100
+++ /tmp/lighttpd2-git-PKGBUILD 2015-01-11 18:32:36.596825927 +0100
@@ -29,7 +29,7 @@
#

./autogen.sh
- ./configure --prefix=/usr --with-lua --with-openssl --with-kerberos5 --with-zlib --with-bzip2 --includedir=/usr/include/lighttpd-2.0.0
+ LUA_LIBS=$(pkg-config --libs lua5.1) LUA_CFLAGS=$(pkg-config --cflags lua5.1) ./configure --prefix=/usr --sbindir=/usr/bin --with-lua --with-openssl --with-kerberos5 --with-zlib --with-bzip2 --includedir=/usr/include/lighttpd-2.0.0
make
sed -i -e 's/^docroot "\/var\/www";/docroot "\/srv\/http";/' contrib/lighttpd.conf
}
@@ -45,6 +45,7 @@
install -D -m0644 contrib/lighttpd.conf "$pkgdir/etc/lighttpd2/lighttpd.conf"
install -D -m0644 contrib/angel.conf "$pkgdir/etc/lighttpd2/angel.conf"
install -D -m0644 contrib/mimetypes.conf "$pkgdir/etc/lighttpd2/mimetypes.conf"
+ install -D -m0644 contrib/systemd/lighttpd2.service "$pkgdir/usr/lib/systemd/system/lighttpd2.service"
}
md5sums=('18c5a930998b90a76e85389d73ecd639'
'SKIP')

vschigrin commented on 2012-10-22 00:05

Заменить строки в PKGBUILD:
./autogen.sh
./configure --prefix=/usr --with-lua --with-openssl --with-kerberos5 --with-zlib --with-bzip2 --includedir=/usr/include/lighttpd-2.0.0
to:
cmake -DBUILD_EXTRA_WARNINGS:BOOL=ON -DWITH_BZIP:BOOL=ON -DWITH_LUA:BOOL=ON -DWITH_OPENSSL:BOOL=ON -DWITH_GNUTLS:BOOL=OFF -DWITH_KERBEROS5:BOOL=ON -DWITH_ZLIB:BOOL=ON -DCMAKE_INSTALL_PREFIX:STRING=/usr
really do not know what to do with "--includedir"