Package Details: linux-ck 6.9.6-1

Git Clone URL: https://aur.archlinux.org/linux-ck.git (read-only, click to copy)
Package Base: linux-ck
Description: The Linux kernel and modules with ck's hrtimer patches
Upstream URL: https://wiki.archlinux.org/index.php/Linux-ck
Licenses: GPL-2.0-only
Provides: KSMBD-MODULE, VIRTUALBOX-GUEST-MODULES, WIREGUARD-MODULE
Replaces: virtualbox-guest-modules-arch, wireguard-arch
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 459
Popularity: 0.30
First Submitted: 2011-07-22 14:51 (UTC)
Last Updated: 2024-06-21 18:26 (UTC)

Latest Comments

« First ‹ Previous 1 .. 300 301 302 303 304 305 306 307 Next › Last »

jakob commented on 2011-08-16 10:28 (UTC)

Here’s one thing which confused me in the PKGBUILD: line 31 should probably read “## LOCALYESCONFIG OPTION” instead of “##LOCALMODCONFIG OPTION” Best, Jakob

<deleted-account> commented on 2011-08-16 03:03 (UTC)

repo seems down for now?

maggie commented on 2011-08-16 00:06 (UTC)

Works great! Thanx!

<deleted-account> commented on 2011-08-15 05:24 (UTC)

Thank you. This kernel works fine!

<deleted-account> commented on 2011-08-13 13:42 (UTC)

@graysky: Default build options. But I just tried again then with the -3 build and the only thing different with build options was setting _makenconfig to true so I could manually set the scheduler to no-op and get rid of the laptop device drivers, and it compiled fine this time :) so all good now.

graysky commented on 2011-08-13 10:53 (UTC)

Forgot to enable the Arch boot logo in the -2 build. The purpose of the -3 build is to have this enabled. This is the only change (trivial I know but I am somewhat OCD). AUR USERS DO NOT NEED TO REBUILD! I only bumped to -3 for consistency between the AUR and the repo.

graysky commented on 2011-08-13 10:46 (UTC)

@poltak - which build options did you enable?

<deleted-account> commented on 2011-08-13 00:54 (UTC)

... CC [M] drivers/scsi/atp870u.o write: Success make[2]: *** [drivers/scsi/atp870u.o] Error 1 make[1]: *** [drivers/scsi] Error 2 make: *** [drivers] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build linux-ck. Just afer compiling all the modules. Anyone know why? This is on a fresh Arch install with Gnome 3.

Zom commented on 2011-08-13 00:18 (UTC)

Would provides= really conflict with the original package though? Isn't it replaces= (and conflicts=) which does that? But yeah, the other way would be to edit the package manually. Would be neat if there was an easier way though. :b

graysky commented on 2011-08-12 23:59 (UTC)

@Zom - I had it configured like that but some discussion on the forums and some conflicts led me to remove the provides array. What I do is to simply edit the .PKGINFO file within the virtualbox package and remove the deps=linux-headers entry. I asked Ionut about it removing the line in the official package but he hasn't answered me yet.