Package Details: lttng-tools 2.13.5-1

Git Clone URL: (read-only, click to copy)
Package Base: lttng-tools
Description: LTTng tracing control tools
Upstream URL:
Licenses: GPL2, LGPL2.1
Provides: lttng
Submitter: christoph.gysin
Maintainer: russkel
Last Packager: russkel
Votes: 8
Popularity: 0.001121
First Submitted: 2015-08-27 06:36 (UTC)
Last Updated: 2023-07-15 14:23 (UTC)

Dependencies (10)

Required by (1)

Sources (1)

Latest Comments

evalan-mfiumara commented on 2021-05-07 09:27 (UTC)

Can confirm this package is broken

collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:668: lttng] Error 1
make[3]: Leaving directory '/home/mattia/.cache/yay/lttng-tools/src/lttng-tools-2.11.0/src/bin/lttng'
make[2]: *** [Makefile:538: all-recursive] Error 1
make[2]: Leaving directory '/home/mattia/.cache/yay/lttng-tools/src/lttng-tools-2.11.0/src/bin'
make[1]: *** [Makefile:526: all-recursive] Error 1
make[1]: Leaving directory '/home/mattia/.cache/yay/lttng-tools/src/lttng-tools-2.11.0/src'
make: *** [Makefile:621: all-recursive] Error 1
==> ERROR: A failure occurred in build().
error making: lttng-tools

qlyoung commented on 2021-02-11 20:18 (UTC)

This package currently doesn't build with the mainline version of lttng-ust due to a link time issue. All it needs is a version bump:

diff --git a/PKGBUILD b/PKGBUILD
index 5ebd358..82bdf41 100644
@@ -3,5 +3,5 @@

 pkgdesc='LTTng tracing control tools'
@@ -24,5 +24,5 @@ optdepends=(
     'man-db: view man pages with the `lttng help` command'


eepp commented on 2020-06-10 17:35 (UTC)

YaLTeR: I don't think so? Where do you see that?

YaLTeR commented on 2019-11-16 14:29 (UTC)

Seems like building requires dtrace (available from

christoph.gysin commented on 2017-09-23 10:02 (UTC)

@milianw: It seems libpfm4 is optional. From the The following items are _optional_ dependencies: [...] - **libpfm >= 4.0**: needed to run the perf regression test suite. - Debian/Ubuntu package: `libpfm4-dev`

milianw commented on 2017-09-19 09:00 (UTC)

Thanks for the update. One more thing I just notice on another machine: lttng-tools now depends on libpfm4 apparently. Note that this clashes with papi currently, so you'll have to force-install libpfm4 manually. I've reported this issue at the papi AUR package site. For lttng-tools, I suggest adding a dependency on the libpfm4 AUR.

christoph.gysin commented on 2017-09-15 18:27 (UTC)

@milianw Good catch, thanks. Fixed, and should not happen anymore :)

milianw commented on 2017-09-12 09:33 (UTC)

The dependency against lttng-ust should be increased to 2.10, since 2.10 of lttng-tools requires some new API and fails to compile against lttng-ust 2.9