Package Details: mapcrafter-git v.2.2.1.r0.g551f150-1

Git Clone URL: https://aur.archlinux.org/mapcrafter-git.git (read-only)
Package Base: mapcrafter-git
Description: A High Performance Minecraft Map Renderer
Upstream URL: http://mapcrafter.org
Keywords: high map mapcrafter minecraft performance renderer world
Licenses: GPL
Submitter: m0r13
Maintainer: m0r13
Last Packager: m0r13
Votes: 4
Popularity: 0.754216
First Submitted: 2015-08-10 21:03
Last Updated: 2016-03-28 17:24

Latest Comments

niva commented on 2015-12-13 13:55

I reinstalled/rebuild it and it is working again. I guess it needed to be rebuild with the newer version of boost.

niva commented on 2015-12-13 13:35

Mapcrafter worked great on my server until a few days.
Now it gives me the error message:

mapcrafter: symbol lookup error: mapcrafter: undefined symbol: _ZN5boost15program_options3argE

My guess is it has something to do with boost-libs because there was an update at 2015-12-10.

should I downgrade boost-libs for now?

m0r13 commented on 2015-10-26 14:12

@Enverex: Aaand it's fixed. :)

m0r13 commented on 2015-10-26 13:27

@Enverex:

That first error happens when your version of boost is upgraded. Mapcrafter is linked to the old version which does not exist anymore. You have to rebuild Mapcrafter then. I'm working on the second error, until then you can add "-DOPT_SKIP_TESTS=ON" as argument to cmake in the pkg build file to skip building the part that's causing the error.

Enverex commented on 2015-10-26 10:10

This appears to have broken. My previously installed version errors out with:

mapcrafter: error while loading shared libraries: libboost_program_options.so.1.58.0: cannot open shared object file: No such file or directory

So I tried to recompile, but that also fails now with a bunch of BOOST related errors:
/tmp/yaourt-tmp-ben/aur-mapcrafter-git/src/mapcrafter-git/src/test/test_image_quantization.cpp:135:39: error: 'BOOST_MESSAGE' was not declared in this scope BOOST_MESSAGE("Testing random image.");
/tmp/yaourt-tmp-ben/aur-mapcrafter-git/src/mapcrafter-git/src/test/test_nbt.cpp:43:209: error: 'BOOST_MESSAGE' was not declared in this scope
/tmp/yaourt-tmp-ben/aur-mapcrafter-git/src/mapcrafter-git/src/accumulator.h:97:41: error: invalid new-expression of abstract class type 'accumulator_type<int>'

So it looks like it really doesn't like this version of BOOST.