Package Details: mozc 2.20.2673.102-2

Git Clone URL: https://aur.archlinux.org/mozc.git (read-only)
Package Base: mozc
Description: A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
Upstream URL: http://code.google.com/p/mozc/
Licenses: custom, BSD
Groups: mozc-im
Conflicts: mozc-server, mozc-utils-gui
Replaces: mozc-server, mozc-utils-gui
Submitter: ponsfoot
Maintainer: ponsfoot
Last Packager: ponsfoot
Votes: 45
Popularity: 0.628940
First Submitted: 2010-08-09 04:27
Last Updated: 2017-04-16 10:04

Pinned Comments

ponsfoot commented on 2013-05-28 07:43

(Update following latest pacman)
Unofficial user repository of Mozc is ready (x86_64 only).
If you want to use the repo, add the following into your /etc/pacman.conf
---
[pnsft-pur]
SigLevel = Optional TrustAll
Server = http://downloads.sourceforge.net/project/pnsft-aur/pur/x86_64
---
You can specify `pacman -S mozc-im' to choose all of Mozc packages.

See https://wiki.archlinux.org/index.php/Mozc for more detail.

Latest Comments

polm23 commented on 2017-09-11 07:14

Minor issue: This requires pkg-config, but it's not listed as a dependency. Noticed setting it up on a fresh machine.

linkmauve commented on 2017-04-20 13:43

Hi, on an up to date ArchLinux, using clang 4.0 from testing, I get this error when building this PKGBUILD:

clang-4.0: error: unknown argument: '-fvar-tracking-assignments'

If I remove it from the DEBUG_CFLAGS and the DEBUG_CXXFLAGS in /etc/makepkg.conf it does build. Since this argument is present in the default configuration, you should probably workaround it somehow.

ponsfoot commented on 2017-04-16 09:59

@Eschwartz:
It should be fixed on 2.20.2673.102-2.
Thank you for the info.

Eschwartz commented on 2017-04-14 17:13

Someone on IRC was having problems building this package with pacaur, and it turned out that the build system was calling `python` when it expected to get `python2`.[1] Doing some investigating in this PKGBUILD, I see you do actually try to work around this.

However... makepkg supports doing the download/extraction/prepare separate from the build, using the logic `makepkg --nobuild && makepkg --noextract`.[2] This is a perfectly valid use case, and PKGBUILDs are expected to work when used like that.

Setting environment variables -- in this case $PATH -- within the prepare() function and expecting them to still be available in the build() function breaks this logic and WILL NOT WORK.
Please fix your PKGBUILD to conform to proper makepkg standards. :)


[1] This is a definite upstream bug, and on my advice that IRC user opened the following bug report which if fixed should remove the need for such hacks: https://github.com/google/mozc/issues/417
[2] pacaur happens to trigger this issue, because it uses separate extraction and build steps for internal reasons. A number of PKGBUILDs that are flawed like this one is, have been discovered as a result.

ponsfoot commented on 2017-01-10 07:38

@mkasu:
Please ask fcitx-mozc maintainer if emacs-mozc is not available in it.

mkasu commented on 2017-01-10 05:18

I'm interested in using emacs-mozc together with fcitx-mozc. Down below you said you'd integrate it into a "mozc-svn" package, but I couldn't find one with that name. Any advice?

ponsfoot commented on 2016-11-15 10:48

@AKremlin:
Please see nash's latest comment.
Is the HiDPI problem fixed on qt5 version? If so, I'll change to use qt5.

AKremlin commented on 2016-11-10 12:21

I understand the reason for keeping the dependency on qt4 until upstream bumps it (it's being held back because of lack of Windows support, but the Github master uses qt5 for linux and OSX). However, I would like to pkgbuild it using qt5, because I can't use the settings dialogue on my high-DPI display. How can I get it to build with qt5? I have qt5 installed on my system.

ponsfoot commented on 2016-10-29 08:30

@nash:
Specifying version is based on Release History.
https://github.com/google/mozc/blob/master/docs/release_history.md
Latest version on it is still using qt4.

nash commented on 2016-10-28 22:54

Hi,

Is there any reason to use QT4 still? The upstream default is QT5 now and it works well on Arch.

--- PKGBUILD.orig 2016-10-28 18:17:19.068887450 +0900
+++ PKGBUILD 2016-10-28 18:19:58.193104521 +0900
@@ -38,7 +38,7 @@
arch=('i686' 'x86_64')
url="http://code.google.com/p/mozc/"
license=('BSD' 'custom')
-makedepends=('python2' 'git' 'ninja' 'clang' 'qt4')
+makedepends=('python2' 'git' 'ninja' 'clang' 'qt5-base')
#source=("${_svndir}/${_svnmod}::svn+${_svntrunk}"
source=(
mozc::git+https://github.com/google/mozc.git#commit=${_mozcrev}
@@ -105,13 +105,6 @@
done
msg2 '====================================================='

- # Use Qt4
- _rcc_loc=`pkg-config QtCore --variable=rcc_location`
- _qt4dir=${_rcc_loc%%/bin/rcc}
- _qt4i=`pkg-config --cflags-only-I QtGui`
- CFLAGS+=" $_qt4i"
- CXXFLAGS+=" $_qt4i"
-
cd "${srcdir}/${pkgbase}/src"

msg "Starting make..."
@@ -122,8 +115,8 @@

unset CC CC_host CC_target CXX CXX_host CXX_target LINK AR AR_host AR_target \
NM NM_host NM_target READELF READELF_host READELF_target
- QTDIR=$_qt4dir GYP_DEFINES="document_dir=/usr/share/licenses/${pkgbase}" \
- python2 build_mozc.py gyp --target_platform=Linux
+ GYP_DEFINES="document_dir=/usr/share/licenses/${pkgbase}" \
+ python2 build_mozc.py gyp --target_platform=Linux --qtver=5
python2 build_mozc.py build -c $_bldtype $_targets

if [[ "$_ibus_mozc" == "yes" ]]; then
@@ -137,7 +130,7 @@
pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)"
arch=('i686' 'x86_64')
groups=('mozc-im')
- depends=('qt4' 'zinnia')
+ depends=('qt5-base' 'zinnia')
replaces=('mozc-server' 'mozc-utils-gui')
conflicts=('mozc-server' 'mozc-utils-gui')
optdepends=('tegaki-models-zinnia-japanese: hand-writing recognition support')
@@ -190,4 +183,4 @@

# Global pkgdesc and depends are here so that they will be picked up by AUR
pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)"
-depends=('qt4' 'ibus>=1.4.1' 'zinnia')
+depends=('qt5-base' 'ibus>=1.4.1' 'zinnia')

All comments