Package Details: emacs-mozc 2.30.5432.102-1

Git Clone URL: https://aur.archlinux.org/emacs-mozc.git (read-only, click to copy)
Package Base: emacs-mozc
Description: Mozc module for Emacs
Upstream URL: https://github.com/google/mozc
Licenses: Apache-2.0 AND BSD-2-Clause AND BSD-3-Clause AND MIT AND NAIST-2003 AND Unicode-3.0 AND LicenseRef-Okinawa-Dictionary
Submitter: Nocifer
Maintainer: Nocifer
Last Packager: Nocifer
Votes: 2
Popularity: 0.136994
First Submitted: 2021-12-26 10:42 (UTC)
Last Updated: 2024-04-07 11:50 (UTC)

Pinned Comments

Nocifer commented on 2022-05-29 21:56 (UTC) (edited on 2023-08-22 09:32 (UTC) by Nocifer)

If you're getting compilation errors, please delete your Bazel cache (~/.cache/bazel by default).

Latest Comments

Nocifer commented on 2024-03-09 13:09 (UTC)

Sorry for the fsck up, I don't even know how I managed to do that. Package permissions have (hopefully) been fixed.

sanlun commented on 2024-03-09 05:56 (UTC)

After upgrading, the permission for /usr/bin/mozc_emacs_helper has been changed to 644.

Nocifer commented on 2022-05-29 21:56 (UTC) (edited on 2023-08-22 09:32 (UTC) by Nocifer)

If you're getting compilation errors, please delete your Bazel cache (~/.cache/bazel by default).

Nocifer commented on 2022-01-13 09:46 (UTC)

Due to a mistake I made in the previous release, newer versions of this package may fail to gracefully update over a preexisting 2.26.4596.102 setup (installing fresh won't be an issue) with the following error (or something similar):

error: failed to prepare transaction (could not satisfy dependencies)
:: installing mozc (2.26.4610.102-1) breaks dependency 'mozc=2.26.4596.102' required by emacs-mozc

The TL;DR version of it is that you will need to do one of the following:

1) Uninstall this package and then reinstall it; or

2) Edit the file /var/lib/pacman/local/emacs-mozc-2.26.4596.102-1/desc and replace

%DEPENDS%
emacs
mozc=2.26.4596.20211205

with

%DEPENDS%
emacs
mozc>=2.26.4596.20211205

and then proceed to update as per usual.

(In other words, the mozc version dependency should be a lax >= instead of a strict =; which AFAIR is also standard PKGBUILD practice, but somehow I completely forgot about it.)

Hopefully this is now fixed, but I'll wait for your input (if any) before I can be certain. Sorry for the inconvenience.