Package Details: mprime-bin 297b1-1

Git Clone URL: https://aur.archlinux.org/mprime-bin.git (read-only)
Package Base: mprime-bin
Description: A GIMPS, distributed computing project client, dedicated to finding Mersenne primes. Precompiled binary version.
Upstream URL: http://www.mersenne.org
Licenses: custom
Conflicts: mprime
Provides: mprime
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 103
Popularity: 0.718716
First Submitted: 2012-01-22 12:11
Last Updated: 2019-04-12 20:09

Latest Comments

« First ‹ Previous 1 2 3 4

Gooberslot commented on 2012-06-04 11:13

This won't build for me. This is the last bit of the output before it fails:

/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libc.a(setitimer.o)
/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libc.a(profil.o) (__setitimer)
/usr/bin/ld: cannot find -lgcc_s
/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libcurl.a(libcurl_la-netrc.o): In function `Curl_parsenetrc':
(.text+0x346): warning: Using 'getpwuid' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i686-pc-linux-gnu/4.7.0/../../../libcurl.a(libcurl_la-curl_addrinfo.o): In function `Curl_getaddrinfo_ex':
(.text+0x81): warning: Using 'getaddrinfo' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
prime.o: In function `pnHttpServer':
prime.c:(.text+0x191c7): warning: Using 'gethostbyname' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/bin/ld: cannot find -lgcc_s
collect2: error: ld returned 1 exit status
make: *** [mprime] Error 1
==> ERROR: A failure occurred in build().
Aborting...

graysky commented on 2012-02-04 11:36

@erg - you want mprime-bin which contains "their" executable which is the only one that works with their servers. When you compile from source as in this pkg, their servers reject your usage perhaps to battle folks hacking the code.

Anonymous comment on 2012-02-02 02:32

I built two computers with the same specs. On the first one, I installed mprime 266-1 a few weeks ago. Now today, I installed mprime 266-2 and it's broken.

erg@ommegang /tmp $ cat prime.log.broken
[Thu Feb 2 02:15:10 2012 - ver 26.6]
Updating computer information on the server
PrimeNet error 7: Invalid parameter
parameter ss: Invalid int value/precision ''

Thanks.

graysky commented on 2012-01-22 12:10

They are statically linked. Good call, kfgz. Note that I am now maintaining two mprime packages:

1) mprime = build from source.
2) mprime-bin = uses pre-compiled binary.

slopjong commented on 2012-01-22 02:20

@kfgz, in mprime's makefile I've found LIBS = ... $(shell pkg-config --static --libs libcurl) ... doesn't this mean that it's still a dependency?

kfgz commented on 2012-01-21 16:50

It looks like that libcurl3 is no longer needed as dependency for i686 and curl for x86_84 too. But maybe I'am mistaken.

graysky commented on 2011-04-23 19:52

Updated to 266

Anonymous comment on 2011-03-10 00:05

the 2 digit numeric pkgver with _filever were there for a reason so you can remove the force flag, but its too late for that now ;/

Svenstaro commented on 2010-10-17 08:21

Got any issues with me putting this into community?